PAT 1132 Cut Integer (20)

Cutting an integer means to cut a K digits long integer Z into two integers of (K/2) digits long integers A and B. For example, after cutting Z = 167334, we have A = 167 and B = 334. It is interesting to see that Z can be devided by the product of A and B, as 167334 / (167 x 334) = 3. Given an integer Z, you are supposed to test if it is such an integer.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<= 20). Then N lines follow, each gives an integer Z (10<=Z<=2^31^). It is guaranteed that the number of digits of Z is an even number.

Output Specification:

For each case, print a single line "Yes" if it is such a number, or "No" if not.

Sample Input:

3
167334
2333
12345678

Sample Output:

Yes
No
No 

思路:注意被除数为0的情况

代码:

#include <iostream>
#include <string>
#include <cmath>
#include <cstdio>
using namespace std;
int main()
{
  int n;
  cin>>n;
  while(n--)
  {
    int num;
    cin>>num;
    string tmp;
    int temp = num;
    while(temp != 0)
    {
      tmp = tmp + static_cast<char>(temp % 10 + '0');
      temp /= 10;
    }
    int len = tmp.length();
    int divide = pow(10,len/2);
    int num1 = num / divide;
    int num2 = num % divide;
    if(num1 != 0 && num2 != 0 && num % (num1 * num2) == 0)
      printf("Yes\n");
    else
      printf("No\n");
  }
  return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值