PAT Tree Traversals Again (25)

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.

\ Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1

思路:push的顺序是先序遍历顺序,pop顺序是中序遍历顺序,用中序和先序构建唯一二叉树,然后后序遍历。

程序:

 

#include <iostream>
#include <cstdio>
#include <vector>
#include <string>
#include <cstring>
#include <cstdlib>
#include <stack>
using namespace std;
struct node
{
  int data;
  struct node * left;
  struct node * right;
};
vector<int> v1, v2;
int n;
struct node* create(int a, int b,int c, int d)
{
  if(a > b)
    return NULL;
  struct node*  root = (struct node*)malloc(sizeof(struct node));
  root->data = v1[a];
  int i;
  for(i = c; i <= d; i++)
  {
    if(v2[i] == v1[a])
    {
      break;
    }
  }
  root->left = create(a+1,a+i-c,c,i-1);
  root->right = create(a+i-c+1,b,i+1,d);
  return root;
}

vector<int> post;
void postorder(node* root)
{
  if(root)
  {
    postorder(root->left);
    postorder(root->right);
    post.push_back(root->data);
  }
}

int main()
{
  cin>>n;
  stack<int> ss;
  int m = n;
  while(m)
  {
    string s;
    cin>>s;
    if(s == "Push")
    {
      int val;
      cin>>val;
      ss.push(val);
      v1.push_back(val);
    }
    else if(s == "Pop")
    {
      v2.push_back(ss.top());
      ss.pop();
      m--;
    }
  }
  struct node* r = create(0,n-1,0,n-1);
  postorder(r);
  int cnt = 0;
  for(int i = 0; i < post.size(); i++)
  {
    if(cnt == 0)
    {
      printf("%d",post[i]);
      cnt++;
    }
    else
      printf(" %d",post[i]);
  }
  cout<<endl;
  return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值