PAT 1072 Gas Station(30 分)

A gas station has to be built at such a location that the minimum distance between the station and any of the residential housing is as far away as possible. However it must guarantee that all the houses are in its service range.

Now given the map of the city and several candidate locations for the gas station, you are supposed to give the best recommendation. If there are more than one solution, output the one with the smallest average distance to all the houses. If such a solution is still not unique, output the one with the smallest index number.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive integers: N (≤10​3​​), the total number of houses; M (≤10), the total number of the candidate locations for the gas stations; K (≤10​4​​), the number of roads connecting the houses and the gas stations; and D​S​​, the maximum service range of the gas station. It is hence assumed that all the houses are numbered from 1 to N, and all the candidate locations are numbered from G1 to GM.

Then K lines follow, each describes a road in the format

P1 P2 Dist

where P1 and P2 are the two ends of a road which can be either house numbers or gas station numbers, and Dist is the integer length of the road.

Output Specification:

For each test case, print in the first line the index number of the best location. In the next line, print the minimum and the average distances between the solution and all the houses. The numbers in a line must be separated by a space and be accurate up to 1 decimal place. If the solution does not exist, simply output No Solution.

Sample Input 1:

4 3 11 5
1 2 2
1 4 2
1 G1 4
1 G2 3
2 3 2
2 G2 1
3 4 2
3 G3 2
4 G1 3
G2 G1 1
G3 G2 2

Sample Output 1:

G1
2.0 3.3

Sample Input 2:

2 1 2 10
1 G1 9
2 G1 20

Sample Output 2:

No Solution

思路:对每个gas station进行Dijkstra求到每个节点的最短的长度,在这些最短长度里面找到最小的那个,然后比较不同的gas station,取使得该最小值最大的gas station。(对于输入的处理,用字符串输入,然后转化成整数,不一定是个位数。。)

程序:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 1020;
const int inf = 999999999;
int dist[maxn];
int road[maxn][maxn];
int vis[maxn];
int n,m,k,ds;
int minDist = inf;
int totDist = 0;
int dijstra(int start)
{
  fill(vis,vis+maxn,0);
  minDist = inf;
  totDist = 0;
  vis[start] = 1;
  for(int i = 1; i <= m + n; i++)
    dist[i] = road[start][i];
  //fill(dist,dist+maxn,inf);
  //dist[start] = 0;
  for(int i = 1; i <= m + n - 1; i++)
  {
    int min = inf;
    int index = 0;
    for(int j = 1; j <= m + n; j++)
    {
      if(dist[j] < min && !vis[j])
      {
        min = dist[j];
        index = j;
      }
    }
    if(index == 0) return -1;
    vis[index] = 1;
    if(index <= n)
    {
      if(dist[index] < minDist)
        minDist = dist[index];
      if(dist[index] > ds)
        return -1;
      else
        totDist += dist[index];
    }
    for(int j = 1; j <= m + n; j++)
    {
      if(!vis[j] && dist[j] > dist[index] + road[index][j])
        dist[j] = dist[index] + road[index][j];
    }
  }
  return 1;
}
int main()
{
  scanf("%d%d%d%d",&n,&m,&k,&ds);
  for(int i = 1; i <= m + n; i++)
  {
    for(int j = 1; j <= m + n; j++)
    {
      road[i][j] = inf;
    }
  }
  fill(vis,vis+maxn,0);
  for(int i = 0; i < k; i++)
  {
    char p1[5],p2[5];
    int dis;
    int a = 0,b = 0;
    scanf("%s %s %d",p1,p2,&dis);
    if(p1[0] != 'G')
    {
      int j = 0;
      while(p1[j] != '\0')
        a = a * 10 + (int)(p1[j++] - '0');
    }
    else
    {
      int j = 1;
      while(p1[j] != '\0')
        a = a * 10 + (int)(p1[j++] - '0');
      a = n + a;
    }
    if(p2[0] != 'G')
    {
      int j = 0;
      while(p2[j] != '\0')
        b = b * 10 + (int)(p2[j++] - '0');
    }
    else
    {
      int j = 1;
      while(p2[j] != '\0')
        b = b * 10 + (int)(p2[j++] - '0');
      b = b + n;
    }
    road[a][b] = road[b][a] = dis;
  }
  int nowDist = -1;
  int nowTotDist = 0;
  bool flag = false;
  int idx = 0;
  for(int i = 1; i <= m; i++)
  {
    int res = dijstra(i+n);
    if(res == 1)
    {
      flag = true;
      if(nowDist < minDist)
      {
        nowDist = minDist;
        nowTotDist = totDist;
        idx = i;
      }
      else if(nowDist == minDist)
      {
        if(totDist < nowTotDist)
        {
          nowTotDist = totDist;
          idx = i;
        }
      }
    }
  }
  if(!flag)
    printf("No Solution\n");
  else
  {
    printf("G%d\n",idx);
    double mean = nowTotDist * 1.0 / n;
    double temp = (double)nowDist;
    printf("%.1lf %.1lf\n",temp,mean);
  }
  return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值