ACM练习—水仙花数

水仙花数

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 0
描述
请判断一个数是不是水仙花数。
其中水仙花数定义各个位数立方和等于它本身的三位数。
输入
有多组测试数据,每组测试数据以包含一个整数n(100<=n<1000)
输入0表示程序输入结束。
输出
如果n是水仙花数就输出Yes
否则输出No
样例输入
153
154
0
样例输出
Yes
No


import java.util.Scanner;
public class Main {


<span style="white-space:pre">	</span>public static void main(String[] args) {


<span style="white-space:pre">		</span>Scanner s = new Scanner(System.in);
<span style="white-space:pre">		</span>int i=0;
<span style="white-space:pre">		</span>int[] num = new int[100];
<span style="white-space:pre">		</span>int[] num1 = null;        // 有效数组
<span style="white-space:pre">		</span>while (true) {
<span style="white-space:pre">			</span>num[i] = s.nextInt();
<span style="white-space:pre">			</span>if(num[i]==0){
<span style="white-space:pre">				</span>break;
<span style="white-space:pre">			</span>}
<span style="white-space:pre">			</span>i+=1;
<span style="white-space:pre">		</span>}
<span style="white-space:pre">		</span>
<span style="white-space:pre">		</span>int size = 0;
<span style="white-space:pre">		</span>for (int j = 0; j < num.length; j++) {  // 判断有效数字长度
<span style="white-space:pre">			</span>if(num[j]!=0){
<span style="white-space:pre">				</span>size++;
<span style="white-space:pre">			</span>}
<span style="white-space:pre">		</span>}
<span style="white-space:pre">		</span>num1 = new int[size];
<span style="white-space:pre">		</span>
<span style="white-space:pre">		</span>for (int j = 0; j < num1.length; j++) {  // 将有效数字放到另一个数组
<span style="white-space:pre">			</span>num1[j] = num[j];
<span style="white-space:pre">		</span>}
<span style="white-space:pre">		</span>
<span style="white-space:pre">		</span>for (int j = 0; j < num1.length; j++) {
<span style="white-space:pre">			</span>int a= num1[j]/100;<span style="white-space:pre">		</span>// 求百位
<span style="white-space:pre">			</span>int b= num1[j]%100/10;<span style="white-space:pre">		</span>// 求十位
<span style="white-space:pre">			</span>int c= num1[j]%10;<span style="white-space:pre">		</span>//求个位
<span style="white-space:pre">			</span>if((a*a*a)+(b*b*b)+(c*c*c)==num1[j]){
<span style="white-space:pre">				</span>System.out.println("Yes");
<span style="white-space:pre">			</span>}else{
<span style="white-space:pre">				</span>System.out.println("No");
<span style="white-space:pre">			</span>}


<span style="white-space:pre">		</span>}
<span style="white-space:pre">	</span>}


}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值