max(与公约数相关的变形题)

题目:

Description
Give two positive integer c, n. You need to find a pair of integer (a, b) satisfy 1 ≤ a, b ≤ n and the greatest common division of a and b is c.

And you need to maximize the product of a and b

Input
The first line has two positive integer c, n

1 ≤ c, n ≤ 109

Output
Output the maximum product of a and b.

If there are no such a and b, just output -1

Sample Input
2 4

Sample Output
8

Hint
a=2, b=4

Source
牛客网2018暑期多校训练营#5

大致题意:

在1~n范围内找出a、b,且c为a和b公约数,求a和b乘积的最大值,若不存在则输出-1。

题解:

由n/c算出有几个符合条件的数,若n/c为1则将最后(即最大那个)的数平方,若n/c大于等于2则取最后两个数相乘,为0则不存在。

Code

#include<bits/stdc++.h>
using namespace std;
int main()
{
    long long c,n,a,b,ans;
    while(~scanf("%lld%lld",&c,&n))
    {
        long long p=n/c;
        if(p==1)ans=p*c*p*c;
        else if(p>=2)ans=p*c*(p-1)*c;
        else ans=-1;
        printf("%lld\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值