2^x mod n = 1 【杭电-HDOJ-1395】 附题

/*
2^x mod n = 1
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11800    Accepted Submission(s): 3673
Problem Description
Give a number n, find the minimum x(x>0) that satisfies 2^x mod n = 1.

Input
One positive integer on each line, the value of n.

Output
If the minimum x exists, print a line with 2^x mod n = 1.

Print 2^? mod n = 1 otherwise.

You should replace x and n with specific numbers.

Sample Input
2
5
 

Sample Output
2^? mod 2 = 1
2^4 mod 5 = 1

*/

#include<stdio.h>
int main()
{
    int i,j,n,s;
    while(~scanf("%d",&n)){
      if(n==1||n%2==0)  
        printf("2^? mod %d = 1\n",n);
      else{
          __int64  s=1;
          int i;
          for(i=1;;i++){
              s*=2;
              s%=n;        //控制s的值在一定范围内,乘2的同时对n取余 
              if(s==1){    //  if(s%n==1) 
                 break;
               }
           }
         printf("2^%d mod %d = 1\n",i,n);
      }
   }
 return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值