hdoj-1395-2^x mod n = 1【欧拉定理】

2^x mod n = 1

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14349 Accepted Submission(s): 4438


Problem Description
Give a number n, find the minimum x(x>0) that satisfies 2^x mod n = 1.

Input
One positive integer on each line, the value of n.

Output
If the minimum x exists, print a line with 2^x mod n = 1.

Print 2^? mod n = 1 otherwise.

You should replace x and n with specific numbers.

Sample Input
  
  
2 5

Sample Output
  
  
2^? mod 2 = 1 2^4 mod 5 = 1

Author
MA, Xiao

Source

Recommend
Ignatius.L | We have carefully selected several similar problems for you: 2462 2421 2521 1695 2466

#include<stdio.h>
int main(){
	int n;
	while(~scanf("%d",&n)){
		if(n==1||n%2==0) printf("2^? mod %d = 1\n",n);
		else{
			int k=2,ncas=1;
		    while(1){
		    	if(k%n==1) break;
		    	k=k%n*2;
		    	++ncas;
		    }
		    printf("2^%d mod %d = 1\n",ncas,n);
		} 
	}
	return 0;
}


欧拉定理 :
对于互质的正整数 a 和 n ,有 a ^φ(n) ≡ 1 mod n 。 φ(n) 指小于n且与n互质的的正整数(包括1)的个数;
因为2与所有奇数都互质,所以对与奇数n,总会存在x,使得:  2^x =1(mod n)

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值