Online Judge

Online Judge

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5070    Accepted Submission(s): 1924


Problem Description
Ignatius is building an Online Judge, now he has worked out all the problems except the Judge System.
The system has to read data from correct output file and user's result file, then the system compare
the two files. If the two files are absolutly same, then the Judge System return "Accepted", else if
the only differences between the two files are spaces(' '), tabs('\t'), or enters('\n'), the Judge
System should return "Presentation Error", else the system will return "Wrong Answer".

Given the data of correct output file and the data of user's result file, your task is to determine
which result the Judge System will return.

 

Input
The input contains several test cases. The first line of the input is a single integer T which is the
number of test cases. T test cases follow.
Each test case has two parts, the data of correct output file and the data of the user's result file.
Both of them are starts with a single line contains a string "START" and end with a single line contains a string "END", these two strings are not the data. In other words, the data is between the two strings. The data will at most 5000 characters.

Output
For each test cases, you should output the the result Judge System should return.

Sample Input
4
START
1 + 2 = 3
END
START
1+2=3
END
START
1 + 2 = 3
END
START
1 + 2 = 3

END
START
1 + 2 = 3
END
START
1 + 2 = 4
END
START
1 + 2 = 3
END
START
1 + 2 = 3
END
 

Sample Output
Presentation Error
Presentation Error
Wrong Answer
Presentation Error

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5070    Accepted Submission(s): 1924


Problem Description
Ignatius is building an Online Judge, now he has worked out all the problems except the Judge System.
The system has to read data from correct output file and user's result file, then the system compare
the two files. If the two files are absolutly same, then the Judge System return "Accepted", else if
the only differences between the two files are spaces(' '), tabs('\t'), or enters('\n'), the Judge
System should return "Presentation Error", else the system will return "Wrong Answer".

Given the data of correct output file and the data of user's result file, your task is to determine
which result the Judge System will return.

 

Input
The input contains several test cases. The first line of the input is a single integer T which is the
number of test cases. T test cases follow.
Each test case has two parts, the data of correct output file and the data of the user's result file.
Both of them are starts with a single line contains a string "START" and end with a single line contains a string "END", these two strings are not the data. In other words, the data is between the two strings. The data will at most 5000 characters.

Output
For each test cases, you should output the the result Judge System should return.

Sample Input
4
START
1 + 2 = 3
END
START
1+2=3
END
START
1 + 2 = 3
END
START
1 + 2 = 3

END
START
1 + 2 = 3
END
START
1 + 2 = 4
END
START
1 + 2 = 3
END
START
1 + 2 = 3
END
 

Sample Output
Presentation Error
Presentation Error
Wrong Answer
Presentation Error

 

#include <stdio.h>
#include <string.h>

const int NUM=5000;
char str1[NUM];
char str2[NUM];

void input(char *str)
{
    char tmp[NUM];
    //gets(tmp);
  //  while(strcmp(tmp,"START") != 0)
       // gets(tmp);

    while(gets(tmp) && strcmp(tmp,"END"))
    {
        if(strlen(tmp) == 0)
            strcat(str,"\n");
        else
            strcat(str,tmp);
    }
}

void DelChar(char *str,int len)
{
    char tmp[NUM];
    int t = 0;
    for(int i = 0; i < len; i++)
    {
        if(str[i] != ' ' && str[i] != '\t' && str[i] != '\n')
            tmp[t++] = str[i];
    }
    tmp[t] = '\0';
    strcpy(str,tmp);
}

int cmp()
{
    int len1,len2;
    len1 = strlen(str1);
    len2 = strlen(str2);

    if(len1 == len2 && !strcmp(str1,str2))
        return 1;
    DelChar(str1,len1);
    DelChar(str2,len2);

    if(!strcmp(str1,str2))
        return 0;
    else
        return -1;

}

int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        getchar();
        while(n--)
        {
            memset(str1,0,sizeof(str1));
            memset(str2,0,sizeof(str2));
            input(str1);
            input(str2);

            int ans = cmp();
            if(ans == 1)
                puts("Accepted");
            else if(ans == 0)
                puts("Presentation Error");
            else
                puts("Wrong Answer");

        }
    }
    return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值