HDoj-1228-A + B

A + B

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12153    Accepted Submission(s): 7103


Problem Description
读入两个小于100的正整数A和B,计算A+B.
需要注意的是:A和B的每一位数字由对应的英文单词给出.
 

Input
测试输入包含若干测试用例,每个测试用例占一行,格式为"A + B =",相邻两字符串有一个空格间隔.当A和B同时为0时输入结束,相应的结果不要输出.
 

Output
对每个测试用例输出1行,即A+B的值.
 

Sample Input
  
  
one + two = three four + five six = zero seven + eight nine = zero + zero =
 

Sample Output
  
  
3 90 96
#include<stdio.h>
#include<string.h>
char s[10][10]={"zero","one","two","three","four","five","six","seven","eight","nine"};
int main()
{
	int i,j,k,sum;
	char str[100];
	char s1[100];
	while(gets(str))
	{
		sum=0;
		k=0;
		for(i=0;i<strlen(str);i++)
		{
			if(str[i]!=' ')
			    s1[k++]=str[i];
			else
			{
				s1[k]='\0';
				k=0;
			
		    	if(strcmp(s1,"+")==0)
			    {
				    continue;
			    }
			
			    else if(str[i+1]=='+' || str[i+1]=='=')
			    {
				    for(j=0;j<10;j++)
				    {
					  if(strcmp(s1,s[j])==0)
					  {
						sum+=j;
						break;
					  } 
				    }
			    }
			    else
			    {
				    for(j=0;j<10;j++)
				    {
					    if(strcmp(s1,s[j])==0)
					    {
						   sum+=10*j;
						   break;
					    }
				    }
			    }
		    }
		}
		if(sum==0)   return 0;
		else         printf("%d\n",sum);
	}
	return 0;
}

#include <iostream>
#include <string>
using namespace std;

string num[10] = {"zero","one","two","three","four","five","six",
				  "seven","eight","nine"};
int strtoi(string str) {
	for (int i = 0; i < 10; i++) {
		if (str == num[i]) return i;
	}
}
int main()
{
	string str;
	while (1) {
		int A = 0, B = 0;
		while (cin >> str && str != "+") {
			A = A*10 + strtoi(str);
		}
		while (cin >> str && str != "=") {
			B = B*10 + strtoi(str);
		}
		if (!A && !B) break;
		cout << A+B << endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值