HDoj-1010-Tempter of the Bone-DFS

Tempter of the Bone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 74250    Accepted Submission(s): 20326


Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
 

Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter;
'S': the start point of the doggie;
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.
 

Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
 

Sample Input
  
  
4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0
 

Sample Output
  
  
NO YES
//本题注意: 
//1.注意修枝!!!可以数数修了多少个支。。 
//2.数组赋值i从1开始,否则超时
//3.输入字符用cin , 用scanf超时
/*做完这个搜索,我算是醉了。。*/ 
#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<iostream>
#include<algorithm>
using namespace std;
int t,n,m;
bool flag;
int stax,stay,endx,endy,wall;
char map[10][10];
int f[4][2]={{-1,0},{1,0},{0,-1},{0,1}};
void DFS(int stx,int sty,int step)
{

	if(stx<1||sty<1||stx>n||sty>m) return;   <span style="font-family: 'Courier New', Courier, monospace;">//修一修</span>
	if(step==t&&stx==endx&&sty==endy)     <span style="font-family: 'Courier New', Courier, monospace;">//修一修</span>

	{
		flag=true;
		return;
	}
	if(flag) return;                    //修一修
	int  temp=t-step-abs(endx-stx)-abs(endy-sty);  //修一修,详解如下!
<span style="white-space:pre">	</span>if(temp<0||temp%2==1)  return;            
		for(int i=0;i<4;i++)
		{
			if(map[stx+f[i][0]][sty+f[i][1]]!='X')
			{
				map[stx+f[i][0]][sty+f[i][1]]='X';
				DFS(stx+f[i][0],sty+f[i][1],step+1);
				map[stx+f[i][0]][sty+f[i][1]]='.';
			}
		}
		return;
}
int main()
{
	while(~scanf("%d%d%d",&n,&m,&t))
	{
		
		if(!m && !n && !t)
		  break;
		wall=0;
		flag=false;
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=m;j++)
			{
				cin>>map[i][j];
				if(map[i][j]=='S')   //标记起点
				{
					stax=i;
					stay=j;
				}
				if(map[i][j]=='D')   //标记终点
				{
					endx=i;
					endy=j;
				}
				if(map[i][j]=='X')    //方便剪枝
				{
					wall++;
				}
			}
		}
		if(t>=m*n-wall)       //修一修
		{
			printf("NO\n");
			continue;
		}
		map[stax][stay]='X';
		DFS(stax,stay,0);
		printf(flag? "YES\n" :"NO\n");
	}
	return 0;
}

     如果abs(x-y)+abs(dx-dy)为偶数,则说明 abs(x-y) 和 abs(dx-dy)的奇偶性相同,需要走偶数步

  如果abs(x-y)+abs(dx-dy)为奇数,那么说明 abs(x-y) 和 abs(dx-dy)的奇偶性不同,需要走奇数步

  而 (ti-setp)表示剩下还需要走的步数,由于题目要求要在 ti时 恰好到达,那么  (ti-step) 与 abs(x-y)+abs(dx-dy) 的奇偶性必须相同

                       因此 temp=ti-step-abs(dx-x)-abs(dy-y) 必然为偶数!


********************************版权所有*******************************************

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值