HDoj-2717-Catch That Cow-BFS

Catch That Cow

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8117    Accepted Submission(s): 2571


Problem Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
 

Input
Line 1: Two space-separated integers: N and K

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
 

Sample Input
  
  
5 17
 

Sample Output
  
  
4
#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<iostream>
#include<algorithm>
#include<queue>
#include<stack>
using namespace std;
const int MAX=1000000;
int f[3][2]={{1,-1},{1,1},{2,0}}; //关键 
int visit[MAX];
int n,m;

struct node
{
	int x,num;
};
void BFS(int x)
{
	
	queue<node>q;
	node p,t;
	t.x=x;
	visit[t.x]=1;
	t.num=0;
	q.push(t);
	while(!q.empty())
	{
		t=q.front();
		q.pop();
		if(t.x==n)
		{
			printf("%d\n",t.num);
			return;
		} 
		for(int i=0;i<3;i++)
		{
			p.x=t.x*f[i][0]+f[i][1];
			if(p.x>=0&&p.x<=MAX&&!visit[p.x])
			{
				p.num=t.num+1;
				q.push(p);
				visit[p.x]=1;
			}
		}
		
	}
} 
int main()
{
		while(~scanf("%d%d",&m,&n))  //直接scanf("%d%d",&m,&n)就WA,这么任性我也是醉了 
		{ 
		       memset(visit,0,sizeof(visit));
		       if(m==n) cout<<"0"<<endl;     //必须判断一下 
	            else	BFS(m);
		 }
		  return 0;
}

 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值