hdoj-3501-Calculation 2-欧拉函数

Calculation 2

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2451    Accepted Submission(s): 1023


Problem Description
Given a positive integer N, your task is to calculate the sum of the positive integers less than N which are not coprime to N. A is said to be coprime to B if A, B share no common positive divisors except 1.
 

Input
For each test case, there is a line containing a positive integer N(1 ≤ N ≤ 1000000000). A line containing a single 0 follows the last test case.
 

Output
For each test case, you should print the sum module 1000000007 in a line.
 

Sample Input
  
  
3 4 0
 

Sample Output
  
  
0 2 题目大意为:给一个整数n,求所有大于1小于n的数中,与n不是互质的数 的和 例如:n=6,
大于1小于6的数中,与6不是互质的数有2,3,4
其和为9

#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<iostream>
#include<algorithm>
#include<queue>
#include<stack>
using namespace std;
__int64 euler(__int64 x)
{
	__int64 res=x;
	for(__int64 i=2;i<=floor(sqrt(x*1.0));i++)
	{
		if(x%i==0)
		{
			res-=res/i;
			while(x%i==0)
			{
				x/=i;
			} 
		}
	} 
	if(x>1) res-=res/x;
	return res;
}
int main()
{
	__int64 n;
	while(~scanf("%I64d",&n),n)//(1 ≤ N ≤ 1000000000).  输入为何要用64??? 
	{
		__int64 ans=(n*(n-1)/2-n*euler(n)/2)%1000000007;
		printf("%I64d\n",ans);
	} 
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值