hdoj3501Calculation 2【欧拉函数】

 


Calculation 2

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3085    Accepted Submission(s): 1272


Problem Description
Given a positive integer N, your task is to calculate the sum of the positive integers less than N which are not coprime to N. A is said to be coprime to B if A, B share no common positive divisors except 1.
 

Input
For each test case, there is a line containing a positive integer N(1 ≤ N ≤ 1000000000). A line containing a single 0 follows the last test case.
 

Output
For each test case, you should print the sum module 1000000007 in a line.
 

Sample Input
      
      
3 4 0
 

Sample Output
      
      
0 2
 

题意求与N不互质的数的和;

欧拉函数性质;与N互质的数的和为N*eular(N)/2;1~N的总和为N*(N-1)/2

#include<cstdio>
#include<cstdlib>
#include<cstring>
#define MOD 1000000007
using namespace std;
long long Eular(long long n){
	long long  ret=1,i;
	for(i=2;i*i<=n;++i){
		if(n%i==0){
			n/=i;ret*=i-1;
			while(n%i==0){
				n/=i;ret*=i;
			}
		}
	}
	if(n>1)ret*=n-1;
	return ret;
}
int main()
{
	long long n;
	while(scanf("%lld",&n),n){
		long long ans=n*(n-1)/2;
		printf("%lld\n",(ans-n*Eular(n)/2)%MOD);
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值