HDU 5510 KMP+优化

HDU 5510 Bazinga

Problem Description
Ladies and gentlemen, please sit up straight.
Don’t tilt your head. I’m serious.
在这里插入图片描述

For n given strings S1,S2,⋯,Sn, labelled from 1 to n, you should find the largest i (1≤i≤n) such that there exists an integer j (1≤j<i) and Sj is not a substring of Si.

A substring of a string Si is another string that occurs in Si. For example, ruiz" is a substring ofruizhang", and rzhang" is not a substring ofruizhang".

Input
The first line contains an integer t (1≤t≤50) which is the number of test cases.
For each test case, the first line is the positive integer n (1≤n≤500) and in the following n lines list are the strings S1,S2,⋯,Sn.
All strings are given in lower-case letters and strings are no longer than 2000 letters.

Output
For each test case, output the largest label you get. If it does not exist, output −1.

Sample Input
4
5
ab
abc
zabc
abcd
zabcd
4
you
lovinyou
aboutlovinyou
allaboutlovinyou
5
de
def
abcd
abcde
abcdef
3
a
ba
ccc

Sample Output
Case #1: 4
Case #2: -1
Case #3: 4
Case #4: 3

题解:
这个题的做法就是KMP算法加一点优化,当一个字符串a是字符串b的连续字串时,那么我们就可以不用再管小的这个字符串a,因为如果大的字符串b属于某个字符串,那么字符串a肯定也属于这个字符串,如果小的字符串a不属于某个字符串,那么字符串b肯定也不属于这个字符串,所以我们只需要判定字符串b即可。这样,用一个二重循环,第一重i从第2个字符串到n,第二重j从1开始到i-1。用KMP算法判断字符串j是不是字符串a的字串。

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

int vis[505],ne[2005],flag;
char str[505][2005];

void next(char *s)
{
    int i,k,len;

    len = strlen(s);
    ne[0] = -1;
    k = -1;
    for(i = 1; i < len; i++)
    {
        while(k > -1 && s[k+1] != s[i])
        {
            k = ne[k];
        }
        if(s[k+1] == s[i])
        {
            k++;
        }
        ne[i] = k;
    }
}

int kmp(char *s1,char *s2)
{
    int i,k,len1,len2;

    len1 = strlen(s1);
    len2 = strlen(s2);
    k = -1;
    next(s2);
    for(i = 0; i < len1; i++)
    {
        while(k > -1 && s2[k+1] != s1[i])
        {
            k = ne[k];
        }
        if(s2[k+1] == s1[i])
        {
            k++;
        }
        if(k == len2-1)
        {
            return 1;
        }
    }
    return 0;
}

int main()
{
    int i,j,k,t,n,ans;

    scanf("%d",&t);
    for(k = 1; k <= t; k++)
    {
        scanf("%d",&n);
        for(i = 0; i < n; i++)
        {
            scanf("%s",str[i]);
        }
        memset(vis,1,sizeof(vis));
        ans = -2;
        for(i = 1; i < n; i++)
        {
            for(j = 0; j < i; j++)
            {
                if(vis[j] != 0)
                {
                    if(kmp(str[i],str[j]) == 1)
                    {
                        vis[j] = 0;
                    }
                    else
                    {
                        ans = i;
                        break;
                    }
                }
            }
        }
        printf("Case #%d: %d\n",k,ans+1);
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值