数据结构实验之链表八:Farey序列

数据结构实验之链表八:Farey序列

Time Limit: 10MS  Memory Limit: 600KB
Problem Description

Farey序列是一个这样的序列:其第一级序列定义为(0/1,1/1),这一序列扩展到第二级形成序列(0/1,1/2,1/1),扩展到第三极形成序列(0/1,1/3,1/2,2/3,1/1),扩展到第四级则形成序列(0/1,1/4,1/3,1/2,2/3,3/4,1/1)。以后在每一级n,如果上一级的任何两个相邻分数a/c与b/d满足(c+d)<=n,就将一个新的分数(a+b)/(c+d)插入在两个分数之间。对于给定的n值,依次输出其第n级序列所包含的每一个分数。

Input
输入一个整数n(0<n<=100)
Output
依次输出第n级序列所包含的每一个分数,每行输出10个分数,同一行的两个相邻分数间隔一个制表符的距离。
Example Input
6
Example Output
0/1   1/6   1/5   1/4   1/3   2/5   1/2   3/5   2/3   3/4
4/5   5/6   1/1
本题的算法不得不说十分奇妙,借了一下别人的思路,要生成n的farey序列,就从1到n的序列依次生成就OK;
#include<stdio.h>
#include<stdlib.h>
typedef struct node{
    int a, b;
    struct node *next;
}*linkList;
void creatList(linkList &L,int n){           //依次建立farey序列
    linkList p, q, tail;
    tail = L->next;
    while(tail->next){
    	p = tail->next;
    	if(p->b + tail->b <= n){            //增加一个新的分数的条件
    		q = new node;
    		q->a = p->a + tail->a;      //新的分数与相邻元素的关系
    		q->b = p->b + tail->b;
    		tail->next = q;
    		q->next = p;
    	}
    	tail = tail->next;
    }
};
void outputData(linkList &L){              //输出序列
	linkList p;  
    p = L->next;  
    int cnt = 0;  
    while(p){  
        cnt++;  
        if(!(cnt%10))  
            printf("%d/%d\n",p->a,p->b);  
        else  
            printf("%d/%d\t",p->a,p->b);  
        p = p->next;  
    }  
}

int main(){
    int n;
    scanf("%d", &n);
    linkList L, p, q;
    L = new node;
    L->next = NULL;
    p = new node, q = new node;
    p->a = 0, p->b = 1;                   //初始的n为1是的两个分数
    q->a = 1, q->b = 1;
    L->next = p;
    p->next = q;
    q->next = NULL;
    for(int i = 2; i <= n; i++)           //循环依次建立序列
    	creatList(L, n);
    outputData(L);
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值