POJ 2018 Best Cow Fences

Best Cow Fences
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 9840 Accepted: 3177

Description

Farmer John's farm consists of a long row of N (1 <= N <= 100,000)fields. Each field contains a certain number of cows, 1 <= ncows <= 2000. 

FJ wants to build a fence around a contiguous group of these fields in order to maximize the average number of cows per field within that block. The block must contain at least F (1 <= F <= N) fields, where F given as input. 

Calculate the fence placement that maximizes the average, given the constraint. 

Input

* Line 1: Two space-separated integers, N and F. 

* Lines 2..N+1: Each line contains a single integer, the number of cows in a field. Line 2 gives the number of cows in field 1,line 3 gives the number in field 2, and so on. 

Output

* Line 1: A single integer that is 1000 times the maximal average.Do not perform rounding, just print the integer that is 1000*ncows/nfields. 

Sample Input

10 6
6 
4
2
10
3
8
5
9
4
1

Sample Output

6500

Source


题意:
求一段连续的长度不小于 F 的序列的最大平均值,
sum[ i ] 表示前缀和,即第1个到第 i 个数的总和,刚开始枚举的起点和终点,不幸TLE。
优化:
若第 j 个到第 i 个这段数的平均值小于第 j 个到第 i + f 个,那么前段数就可以忽略不算了!
代码:
#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn = 1e5 + 10;
int sum[maxn];

int main()
{
    int n, f, a;
    while(~scanf("%d%d", &n, &f)) {

        for(int i = 1; i <= n; i++) {
            scanf("%d", &a);
            sum[i] = sum[i - 1] + a;        //前缀和
        }
        int Max = 0;
        for(int i = 0, j = 0; i <= n - f; i++) {    //乘,避免浮点误差
            if(i > j && (sum[i] - sum[j]) * (i + f - j) < (sum[i + f] - sum[j]) * (i - j)) {
                j = i;                                  //优化
            }
            Max = max(Max, 1000 * (sum[i + f] - sum[j]) / (i + f - j));
        }
        printf("%d\n", Max);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值