POJ 2352 Stars 线段树

Stars
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 40218 Accepted: 17470

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

Source



点击打开题目链接

题目大意:

在坐标系上有n个星星,如果某个星星坐标为(x, y), 它的左下位置为:(x0,y0),x0<=x 且y0<=y。如果左下位置有a个星星,就表示这个星星属于level a

按照y递增,如果y相同则x递增的顺序给出n个星星,求出所有level水平的数量。


分析与总结:

因为输入是按照按照y递增,如果y相同则x递增的顺序给出的, 所以,对于第i颗星星,它的 level 就是之前出现过的星星中,横坐标x小于等于i星横坐标的那些星星的总数量(前面的y一定小于等于后面的y)。

所以,需要找到一种数据结构来记录所有星星的x值,方便的求出所有值为0~x的星星总数量。

树状数组和线段树都是很适合处理这种问题,这里用线段树解决,树状数组见代码下方。

代码:

#include <cstdio>
#include <iostream>
using namespace std;
#define lson 2 * o, L, M            //左儿子
#define rson 2 * o + 1, M + 1, R    //右儿子

const int MAXN = 32000 + 10;
int sum[MAXN << 2], level[MAXN << 2];   //注意这两个数组的大小
int N, X, Y;
/**
 查询区间 [ql , qr] 的和
 o 是当前结点的编号,L 和 R 是当前结点的左右端点
*/
int query(int o, int L, int R, int ql, int qr)
{
    int M = (L + R) / 2;            //区间中点
    int ans = 0;
    if (ql <= L && qr >= R) return sum[o];  //当前结点完全包含在查询区间内
    if (ql <= M) ans += query(lson, ql, qr);    //往左走,查询左子树
    if (qr > M) ans += query(rson, ql, qr);     //往右走,查询右子树
    return ans;                                 //返回本次查询结果
}
/**
 更新树状数组
 p 和 v 分别代表修改点的位置和要修改的数值
*/
void update(int o, int L, int R, int p, int v)
{
    sum[o] += v;            //更新当前结点
    if (L == R) return;     //是叶子结点,返回
    else
    {
        int M = (L + R) / 2;
        if (p <= M) update(lson, p, v); //修改点的位置不在中点右侧,更新左子树
        else update(rson, p, v);        //否则,更新右子树
    }
}

int main()
{
    scanf("%d", &N);
    for (int i = 0; i < N; i++)
    {
        scanf("%d%d", &X, &Y);
        X += 1;             //坐标可能为0
        level[query(1, 1, MAXN, 1, X)]++; //查询并记录水平

        update(1, 1, MAXN, X, 1);           //更新
    }
    for (int i = 0; i < N; i++) printf("%d\n", level[i]);
    return 0;
}

点击打开博客链接树状数组解决
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值