poj 2352 Stars 线段树基础

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.
Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
Sample Input
5
1 1
5 1
7 1
3 3
5 5
Sample Output
1
2
1
1
0
Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed. 

题意:给你一些点,给出一个点覆盖点的概念,如果点a的坐标满足其横纵坐标都小于点b,这时就叫做b覆盖a,给你一些点,然后让你写出覆盖点数为1~n-1的点的个数,由于给出的点已经按y坐标升序,所以只要按照x坐标找点就可以了,给出一点(x,y)然后找前边横坐标0~x的点的个数,这时就可以用线段树了(毕竟线段树可以计数嘛^@^)

ac代码:

#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;
#define MAX 32005
struct node
{
 int left, right;
 int num;
}pt[MAX*3];
int n;
int result[MAX/2];
int x, y;
void build_tree(int l, int r, int pos)
{
 pt[pos].left = l;
 pt[pos].right = r;
 pt[pos].num = 0;
 if(l == r) return ;
 int mid = (l+r)/2;
 build_tree(l,mid,pos*2);
 build_tree(mid+1,r,pos*2+1);
}
int find(int l, int r, int pos)
{
 if(pt[pos].left == l && pt[pos].right == r)
  return pt[pos].num;
 int sum = 0;
 int mid = (pt[pos].left+pt[pos].right)/2;
 if(l >mid)
  sum += find(l,r,pos*2+1);
 else if(r <=mid)
  sum += find(l,r,2*pos);
 else
  sum += (find(l,mid,2*pos) + find(mid+1,r,2*pos+1));
 return sum;
}
void add(int x, int pos)
{
 pt[pos].num++;
 if(pt[pos].left == pt[pos].right && pt[pos].right == x)
  return ;
 int mid = (pt[pos].left+pt[pos].right)/2;
 if(x <= mid)
  add(x,2*pos);
 else
  add(x,2*pos+1);
}
int main()
{
 while(scanf("%d",&n) != EOF)
 {
  memset(result,0,sizeof(result));
  build_tree(0,MAX,1);
  for(int i = 0; i < n; ++i)
  {
   scanf("%d %d",&x, &y);
   result[find(0,x,1)]++;
   add(x,1);
  }
  for(int k = 0; k < n; ++k)
   printf("%d\n",result[k]);
 }
 return 0;
}


写完一遍程序一调就炸,不知道错哪了非常郁闷呢。。。后来终于找到错误了,

if(l >mid)
  sum += find(l,r,pos*2+1);
 else if(r <=mid)
  sum += find(l,r,2*pos);
 else
  sum += (find(l,mid,2*pos) + find(mid+1,r,2*pos+1));

原来错写成了

if(l >=mid)//错误处
  sum += find(l,r,pos*2+1);
 else if(r <mid)
  sum += find(l,r,2*pos);
 else
  sum += (find(l,mid,2*pos) + find(mid+1,r,2*pos+1));

哎,前一段是l~mid   后一段是mid+1~r

如果按以前的错误代码岂不是把mid归到后一段了,教训啊

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值