对象数组

Description
建立一个对象数组,内放五个学生的数据(学号、成绩),用指针指向数组首元素,输出第1,3,5个学生的数据

Input
输入五个学生资料,如下:
1001 98
1002 76
1003 65
1004 90
1005 77

Output
输出1,3,5个学生的数据:
1001 98
1003 65
1005 77

Sample Input
Copy sample input to clipboard
1001 98
1002 76
1003 65
1004 90
1005 77

Sample Output
1001 98
1003 65
1005 77

代码实现:

#include<iostream>
using namespace std;

class Student{
    private:
        int number;
        int score;

    public:

        Student(){
            number = score = 0;
        }

        void setdata()
        {
            cin >> number >> score;
        }

        void display()
        {
            cout << number << " " << score << endl;
        }
};

int main()
{
    Student stu[5];
    for(int i = 0; i < 5; i++){
        stu[i].setdata();
    }

    for(int i = 0; i < 5; i += 2){
        stu[i].display();
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值