HDU 1686Oulipo ———————Hash or KMP

Oulipo



Oulipo

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 22302    Accepted Submission(s): 8608



Problem Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e’. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive ‘T’s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A’, ‘B’, ‘C’, …, ‘Z’} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.


 


Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with |W| ≤ |T| ≤ 1,000,000.

 


Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.


 


Sample Input

  
  
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

 


Sample Output

  
  
1
3
0

 


Source


 


Recommend

lcy   |   We have carefully selected several similar problems for you:   1358  3336  3746  2203  3068 

 


Statistic |  Submit |  Discuss | Note





Hash_code:

Problem : 1686 ( Oulipo )     Judge Status : Accepted
RunId : 25951470    Language : G++    Author : 311709001223
Code Render Status : Rendered By HDOJ G++ Code Render Version 0.01 Beta

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
const int MAXN=1e6+7;
const int MAXM=1e4+7;
const int base=233;
char str1[MAXM],str2[MAXN];
ull Hash[MAXN];
int t;
int id[30],idx;
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s %s",str1,str2);
        int ans=0;
        int len1=strlen(str1);
        int len2=strlen(str2);
        if(len1>len2)
        {
            printf("%d\n",ans);
            continue;
        }
        ull sh1=0;//字串的hash值
        ull sh2=0;//母串的hash值,先计算前len1 长度的hash值
        ull hb=1;
        for(int i=0;i<len1;i++) sh1=sh1*base+str1[i]-'A';
        for(int i=0;i<len1;i++) sh2=sh2*base+str2[i]-'A';
        for(int i=0;i<len1;i++) hb*=base;
        for(int i=0;i+len1<=len2;i++)
        {
            if(sh1==sh2)    ans++;
            sh2=sh2*base -(str2[i]-'A')*hb + (str2[i+len1]-'A');
        }
        printf("%d\n",ans);
    }
    return 0;
}



KMP_code

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAXN=1e6+7;
int slen,plen;
char s[MAXN],p[MAXN];
int Next[MAXN];
void preKMP(char x[],int m,int kmpNext[])
{
    int i,j;
    j=kmpNext[0]=-1;
    i=0;
    while(i<m)
    {
        while(-1!=j && x[i]!=x[j])  j=kmpNext[j];
        if(x[++i]==x[++j])  kmpNext[i]=kmpNext[j];
        else    kmpNext[i]=j;
    }
}
int KMP(char x[],int m,char y[],int n)
{
    int i,j;
    int ans=0;
    preKMP(x,m,Next);
    i=j=0;
    while(i<n)
    {
        while(-1!=j && y[i]!=x[j])  j=Next[j];
        i++;j++;
        if(j>=m)
        {
            ans++;
            j=Next[j];
        }
    }
    return ans;
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s %s",p,s);
        plen=strlen(p);
        slen=strlen(s);
        printf("%d\n",KMP(p,plen,s,slen));
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值