HDU 3746 Cyclic Nacklace——————KMP_next[]数组的利用

Cyclic Nacklace

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 15070    Accepted Submission(s): 6272


Problem Description
CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of “HDU CakeMan”, he wants to sell some little things to make money. Of course, this is not an easy task.

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl’s fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls’ lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet’s cycle is 9 and its cyclic count is 2:

Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden.
CC is satisfied with his ideas and ask you for help.
 

Input
The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by ‘a’ ~’z’ characters. The length of the string Len: ( 3 <= Len <= 100000 ).
 

Output
For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.
 

Sample Input
  
  
3
aaa
abca
abcde
 

Sample Output
  
  
0
2
5


题意:给你一个字符串,并问你在该字符串末尾最少补充多少个字符,可以使得这个字符串获得周期性。
比如:

  • aaaaa a a a a a
    ans=0
  • abcab a b c a b
    ans=1(补上一个c)
  • abcdeabcdeabcdeabc a b c d e a b c d e a b c d e a b c
    ans=2(补上de,该串就具有周期性了)

next n e x t 数组记录的是最长公共前后缀的长度
这道题我们根据next数组的性质(不让next数组回溯)
可以找到最长的公共前后缀

比如

  • abcdeabcdeabcdeabc a b c d e a b c d e a b c d e a b c

的最长公共前后缀长度是 next[len]=13 n e x t [ l e n ] = 13 其中公共前后缀是 abcdeabcdeabc a b c d e a b c d e a b c

如果把该串补全,变成周前串后就是 abcdeabcdeabcdeabcde a b c d e a b c d e a b c d e a b c d e
单位串 abcde a b c d e ,长度是5
那么我们只需要找到原串在尾部还未不全的,比单位小的子串,
比如该串( abcdeabcdeabcdeabc a b c d e a b c d e a b c d e a b c ),就是 abc a b c ,这是未补全的串,长度是3
那么如果我们找到了单位串的长度,以及未补全串的长度
那么结果就是 ans= a n s = 单位串的长度 – 未补全串的长度

单位串的长度 L=lennext[len] L = l e n − n e x t [ l e n ]

未补全串的长度 l=next[len] % L l ′ = n e x t [ l e n ]   %   L

所以结果就是 ans=Ll a n s = L − l ′

正如这个例子:

abcdeabcdeabcdeabc a b c d e a b c d e a b c d e a b c

len=18 l e n = 18
next[len]=13 n e x t [ l e n ] = 13
L=lennext[len]=5 L = l e n − n e x t [ l e n ] = 5
l=next[len] % L=3 l ′ = n e x t [ l e n ]   %   L = 3
ans=Ll=2 a n s = L − l ′ = 2
所以再补两个字母 de d e 就行了


#include<bits/stdc++.h>
using namespace std;
const int MAXN=1e5+9;
char s[MAXN];
int slen,nex[MAXN];

void GetNext()
{
    int i,j;
    i=0;
    j=nex[0]=-1;
    while(i<slen)
    {
        while(-1!=j && s[i]!=s[j])  j=nex[j];
        nex[++i]=++j;
    }
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s",s);
        slen=strlen(s);
        GetNext();
//        for(int i=0;i<=slen;i++)
//            printf("next[%2d]:%2d\n",i,nex[i]);
        int l=slen-nex[slen];//最长子串的长度
//        printf("slen:%d  l:%d   nex[slen]:%d\n",slen,l,nex[slen]);
        if( l!=slen && slen%l==0)//正好能够形成环
            printf("0\n");
        else
            printf("%d\n",l-nex[slen]%l);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值