POJ 2084 Game of Connections ——————Catalan 数

Game of Connections

Language:Default
Game of Connections
Time Limit: 1000MSMemory Limit: 30000K
Total Submissions: 9203Accepted: 4512

Description

This is a small but ancient game. You are supposed to write down the numbers 1, 2, 3, … , 2n - 1, 2n consecutively in clockwise order on the ground to form a circle, and then, to draw some straight line segments to connect them into number pairs. Every number must be connected to exactly one another.
And, no two segments are allowed to intersect.
It’s still a simple game, isn’t it? But after you’ve written down the 2n numbers, can you tell me in how many different ways can you connect the numbers into pairs? Life is harder, right?

Input

Each line of the input file will be a single positive number n, except the last line, which is a number -1.
You may assume that 1 <= n <= 100.

Output

For each n, print in a single line the number of ways to connect the 2n numbers into pairs.

Sample Input

2
3
-1

Sample Output

2
5

Source

—– Catalan C a t a l a n 数 (卡特兰数,又称卡塔兰数)是组合数学中一个常出现在各种计数问题中出现的数列。前几项为 1 , 1 , 2 , 5 , 14 , 42 , 132  1   ,   1   ,   2   ,   5   ,   14   ,   42   ,   132   ⋯ h(1)=1 , h(0)=1 , Catalan  h ( 1 ) = 1   ,   h ( 0 ) = 1   ,   C a t a l a n   数满足递归式:

h(n)=h(0)×h(n1) + h(1)×h(n2) +  +h(n1) × h(0)(n2) h ( n ) = h ( 0 ) × h ( n − 1 )   +   h ( 1 ) × h ( n − 2 )   +   ⋯   + h ( n − 1 )   ×   h ( 0 ) ( n ≥ 2 )

也就是
h(n)=i=0n1h(i)h(ni1) h ( n ) = ∑ i = 0 n − 1 h ( i ) h ( n − i − 1 )

另类递归式:

h(n) = 4×n2n+1×h( n1) h ( n )   =   4 × n − 2 n + 1 × h (   n − 1 )

该递推关系的的解是:
h(n)=C n 2nn+1(n=1,2,3) h ( n ) = C   2 n   n n + 1 ( n = 1 , 2 , 3 ⋯ )


由于Catalan数非常大,需要用大数来解决

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
const int MAX=100;
const int BASE=10000;

void multiply(int a[],int Max,int b)//大数乘法
{
    int i,array=0;
    for(i=Max -1;i>=0;i--)
    {
        array += b*a[i];
        a[i] = array%BASE;
        array /= BASE;
    }
}

void divide(int a[],int Max,int b)//大树除法
{
    int i,div=0;
    for(i=0;i<Max;i++)
    {
        div=div*BASE + a[i];
        a[i] = div / b;
        div %= b;
    }
}
int main()
{
    int a[101][MAX],i,j,n;
    memset(a[1],0,MAX*sizeof(int));
    for(i=2,a[1][MAX-1]=1;i<101;i++)
    {
        memcpy(a[i],a[i-1],MAX*sizeof(int));    //h[i] = h[i-1]
        multiply(a[i],MAX,4*i-2);               //h[i] *= (4*i-2)
        divide(a[i],MAX,i+1);                   //h[i] /= (i+1)
    }
    while(cin>>n)
    {
        if(n==-1)   break;
        for(i=0;i<MAX && a[n][i]==0 ; i++) ;
        cout<<a[n][i++];
        for(;i<MAX;i++)
            printf("%04d",a[n][i]);
        cout<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
未来社区的建设背景和需求分析指出,随着智能经济、大据、人工智能、物联网、区块链、云计算等技术的发展,社区服务正朝着字化、智能化转型。社区服务渠道由分散向统一融合转变,服务内容由通用庞杂向个性化、服务导向转变。未来社区将构建字化生态,实现据在线、组织在线、服务在线、产品智能和决策智能,赋能企业创新,同时注重人才培养和科研平台建设。 规划设计方面,未来社区将基于居民需求,打造以服务为中心的社区管理模式。通过统一的服务平台和应用,实现服务内容的整合和优化,提供灵活多样的服务方式,如推送式、订阅式、热点式等。社区将构建据与应用的良性循环,提高服务效率,同时注重生态优美、绿色低碳、社会和谐,以实现幸福民生和产业发展。 建设运营上,未来社区强调科学规划、以人为本,创新引领、重点突破,统筹推进、整体提升。通过实施院落+社团自治工程,转变政府职能,深化社区自治法制化、信息化,解决社区治理中的重点问题。目标是培养有活力的社会组织,提高社区居民参与度和满意度,实现社区治理服务的制度机制创新。 未来社区的字化解决方案包括信息发布系统、服务系统和管理系统。信息发布系统涵盖公共服务类和社会化服务类信息,提供政策宣传、家政服务、健康医疗咨询等功能。服务系统功能需求包括办事指南、公共服务、社区工作参与互动等,旨在提高社区服务能力。管理系统功能需求则涉及院落管理、社团管理、社工队伍管理等,以实现社区治理的现代化。 最后,未来社区建设注重整合政府、社会组织、企业等多方资源,以提高社区服务的效率和质量。通过建立社区管理服务综合信息平台,提供社区公共服务、社区社会组织管理服务和社区便民服务,实现管理精简、高效、透明,服务快速、便捷。同时,通过培育和发展社区协会、社团等组织,激发社会化组织活力,为居民提供综合性的咨询和服务,促进社区的和谐发展。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值