百练练习——1001:Exponentiation

1001:Exponentiation

描述

Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems.

This problem requires that you write a program to compute the exact value of Rnwhere R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.
就是一个大数求幂

输入
The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.
输出
The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don’t print the decimal point if the result is an integer.
样例输入

95.123 12
0.4321 20
5.1234 15
6.7592 9
98.999 10
1.0100 12

样例输出

548815620517731830194541.899025343415715973535967221869852721 .00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201

我的思路是先找到小数点的位置,让后将数转化为整数,直接用pow函数计算,最后转换为列表后插入小数点,但是不知道为什么不能AC .希望有大神看到指教

x = 0
y = 0
a,b= input().split()
for i in range(0,len(a)):
    if(a[i]!='.'):
        x=int(a[i])+x*10
    if(a[i]=='.'):
        y=(len(a)-i-1)*int(b)
tm=(pow(x,int(b)))
l=list(str(tm))
if(tm!=0):
    while(y>len(l)):
        l.insert(0,"0")
    if(y!=0):
        l.insert(-y, ".")
        while (l[len(l) - 1] == "0"):
            l = l[0:len(l) - 1]
            if(l[len(l) - 1] == "."):
                l = l[0:len(l) - 1]
                break
for i in range(0,len(l)):
    print(l[i],end="")

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值