PAT乙级题解(1032. 挖掘机技术哪家强(20))初涉map和map-vector转换对value排序

1032. 挖掘机技术哪家强(20)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
CHEN, Yue

为了用事实说明挖掘机技术到底哪家强,PAT组织了一场挖掘机技能大赛。现请你根据比赛结果统计出技术最强的那个学校。

输入格式:

输入在第1行给出不超过105的正整数N,即参赛人数。随后N行,每行给出一位参赛者的信息和成绩,包括其所代表的学校的编号(从1开始连续编号)、及其比赛成绩(百分制),中间以空格分隔。

输出格式:

在一行中给出总得分最高的学校的编号、及其总分,中间以空格分隔。题目保证答案唯一,没有并列。

输入样例:
6
3 65
2 80
1 100
2 70
3 40
3 0
输出样例:

2 150

思路一:输入一个保存一个,最后sort排序。

思路二:突然想到STL内的map容器,可以快速查找主键。但是后来对value排序遇到问题,不能使用sort,百度后找到了map-vector转换后可以使用sort,成功写出答案。

#include <iostream>
#include <algorithm>
using namespace std;

typedef struct school {
	int id;
	int score = 0;
} school;

int cmp(school x, school y)
{
	return x.score > y.score;
}

int main()
{
	int t;
	cin >> t;
	school *id = new school[t+1];
	int School_ID, score;
	for (int i = 1; i <= t; i++) {
		cin >> School_ID >> score;
		id[School_ID].id = School_ID;
		id[School_ID].score += score;
	}

	sort(id + 1, id + t + 1,cmp);
	cout << id[1].id << " " << id[1].score;
	return 0;
}
#include <iostream>
#include <algorithm>
#include <map>
#include <vector>
using namespace std;

map<int, int> id_score;
map<int, int>::iterator it;//智能指针

int cmp(pair<int, int>& x,pair<int, int>& y)
{
	return x.second > y.second;
}

void SortScoreByValue(map<int, int>& id_score, vector<pair<int, int>>& vec_id_socre)
{
	for (map<int, int>::iterator curr = id_score.begin(); curr != id_score.end(); curr++)
		vec_id_socre.push_back(make_pair(curr->first, curr->second));//保存

	sort(vec_id_socre.begin(), vec_id_socre.end(), cmp);
}

int main()
{
	int t;
	cin >> t;
	int id, score;
	for (int i = 0; i < t; i++) {
		cin >> id >> score;
		it = id_score.find(id);
		if (it == id_score.end()) {//没有find这个主键
			id_score.insert(make_pair(id, score));//make_pair这一条记录
		} else{	//找到了这个主键
			it->second += score;//把这个score加上去
		}
	}
	
	vector<pair<int, int>> vec_id_socre;//建立vector保存map
	SortScoreByValue(id_score, vec_id_socre);

	cout << vec_id_socre.front().first << " " << vec_id_socre.front().second << endl;//输出vector中的第一个元素的first 和 second即可
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值