8576 顺序线性表的基本操作

Description 编写算法,创建初始化容量为LIST_INIT_SIZE的顺序表T,并实现插入、删除、遍历操作。本题目给出部分代码,请补全内容。
#include<stdio.h>
#include<malloc.h>
#define OK 1
#define ERROR 0
#define LIST_INIT_SIZE 100
#define LISTINCREMENT 10
#define ElemType int

typedef struct
{
int *elem;
int length;
int listsize;
}SqList;

int InitList_Sq(SqList &L)
{
// 算法2.3,构造一个空的线性表L,该线性表预定义大小为LIST_INIT_SIZE
// 请补全代码

}

int Load_Sq(SqList &L)
{
// 输出顺序表中的所有元素
int i;
if() printf(“The List is empty!”); // 请填空
else
{
printf("The List is: ");
for(
) printf("%d “,_________________________); // 请填空
}
printf(”\n");
return OK;
}

int ListInsert_Sq(SqList &L,int i,int e)
{
// 算法2.4,在顺序线性表L中第i个位置之前插入新的元素e
// i的合法值为1≤i≤L.length +1
// 请补全代码

}

int ListDelete_Sq(SqList &L,int i, int &e)
{
// 算法2.5,在顺序线性表L中删除第i个位置的元素,并用e返回其值
// i的合法值为1≤i≤L.length
// 请补全代码

}

int main()
{
SqList T;
int a, i;
ElemType e, x;
if() // 判断顺序表是否创建成功
{
printf(“A Sequence List Has Created.\n”);
}
while(1)
{
printf(“1:Insert element\n2:Delete element\n3:Load all elements\n0:Exit\nPlease choose:\n”);
scanf("%d",&a);
switch(a)
{
case 1: scanf("%d%d",&i,&x);
if(
) printf(“Insert Error!\n”); // 判断i值是否合法,请填空
else printf(“The Element %d is Successfully Inserted!\n”, x);
break;
case 2: scanf("%d",&i);
if(_________________________) printf(“Delete Error!\n”); // 判断i值是否合法,请填空
else printf(“The Element %d is Successfully Deleted!\n”, e);
break;
case 3: Load_Sq(T);
break;
case 0: return 1;
}
}
}

输入格式
测试样例格式说明:
根据菜单操作:
1、输入1,表示要实现插入操作,紧跟着要输入插入的位置和元素,用空格分开
2、输入2,表示要实现删除操作,紧跟着要输入删除的位置
3、输入3,表示要输出顺序表的所有元素
4、输入0,表示程序结束

输入样例
1
1 2
1
1 3
2
1
3
0

输出样例
A Sequence List Has Created.
1:Insert element
2:Delete element
3:Load all elements
0:Exit
Please choose:
The Element 2 is Successfully Inserted!
1:Insert element
2:Delete element
3:Load all elements
0:Exit
Please choose:
The Element 3 is Successfully Inserted!
1:Insert element
2:Delete element
3:Load all elements
0:Exit
Please choose:
The Element 3 is Successfully Deleted!
1:Insert element
2:Delete element
3:Load all elements
0:Exit
Please choose:
The List is: 2
1:Insert element
2:Delete element
3:Load all elements
0:Exit
Please choose:

#include<stdio.h>
#include<malloc.h>
#define OK 1 
#define ERROR 0
#define LIST_INIT_SIZE 100
#define LISTINCREMENT 10
#define ElemType int

typedef struct
{
	int* elem;
	int length;
	int listsize;
}SqList;

int InitList_Sq(SqList& L)
{
	// 算法2.3,构造一个空的线性表L,该线性表预定义大小为LIST_INIT_SIZE
	// 请补全代码
	L.elem = (int*)malloc(sizeof(int) * LIST_INIT_SIZE);
	if (!L.elem)return ERROR;
	L.length = 0;
	L.listsize = LIST_INIT_SIZE;
	return OK;
}

int Load_Sq(SqList& L)
{
	// 输出顺序表中的所有元素
	int i;
	if (L.length == 0) printf("The List is empty!");  // 请填空
	else
	{
		printf("The List is: ");
		for (i = 0; i < L.length; i++) printf("%d ", L.elem[i]);  // 请填空
	}
	printf("\n");
	return OK;
}

int ListInsert_Sq(SqList& L, int i, int e)
{
	// 算法2.4,在顺序线性表L中第i个位置之前插入新的元素e
	// i的合法值为1≤i≤L.length +1
	// 请补全代码
	if (i < 1 || i > L.length + 1)
		return ERROR;
	int *t = NULL;
	if (L.length + 1 >= L.listsize)
	{
		t = (int*)realloc(L.elem, sizeof(int) * (L.listsize + LISTINCREMENT));
		if (t)
			L.elem = t;
		else
			return ERROR;
		L.listsize += LISTINCREMENT;
	}

	int j;
	for (j = L.length; j >= i; j--)
		L.elem[j] = L.elem[j - 1];
	L.elem[i - 1] = e;
	L.length++;
	return OK;
}

int ListDelete_Sq(SqList& L, int i, int& e)
{
	// 算法2.5,在顺序线性表L中删除第i个位置的元素,并用e返回其值
	// i的合法值为1≤i≤L.length
	// 请补全代码
	if (i < 1 || i > L.length)
		return ERROR;
	e = L.elem[i - 1];
	int j;
	for (j = i-1; j < L.length-1; j++)
		L.elem[j] = L.elem[j + 1];
	L.length--;
	return OK;
}

int main()
{
	SqList T;
	int a, i;
	ElemType e, x;
	if (InitList_Sq(T))    // 判断顺序表是否创建成功
	{
		printf("A Sequence List Has Created.\n");
	}
	while (1)
	{
		printf("1:Insert element\n2:Delete element\n3:Load all elements\n0:Exit\nPlease choose:\n");
		scanf("%d", &a);
		switch (a)
		{
		case 1: scanf("%d%d", &i, &x);
			if (!ListInsert_Sq(T,i,x)) printf("Insert Error!\n"); // 判断i值是否合法,请填空
			else printf("The Element %d is Successfully Inserted!\n", x);
			break;
		case 2: scanf("%d", &i);
			if (!ListDelete_Sq(T,i,e)) printf("Delete Error!\n"); // 判断i值是否合法,请填空
			else printf("The Element %d is Successfully Deleted!\n", e);
			break;
		case 3: Load_Sq(T);
			break;
		case 0: return 1;
		}
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值