SCAU 数据结构 8576 顺序线性表的基本操作

Description
编写算法,创建初始化容量为LIST_INIT_SIZE的顺序表T,并实现插入、删除、遍历操作。本题目给出部分代码,请补全内容。

#include<stdio.h>
#include<malloc.h>
#define OK 1
#define ERROR 0
#define LIST_INIT_SIZE 100
#define LISTINCREMENT 10
#define ElemType int

typedef struct
{
int *elem;
int length;
int listsize;
}SqList;

int InitList_Sq(SqList &L)
{
// 算法2.3,构造一个空的线性表L,该线性表预定义大小为LIST_INIT_SIZE
// 请补全代码

}

int Load_Sq(SqList &L)
{
// 输出顺序表中的所有元素
int i;
if() printf(“The List is empty!”); // 请填空
else
{
printf("The List is: ");
for(
) printf(“%d “,_________________________); // 请填空
}
printf(”\n”);
return OK;
}

int ListInsert_Sq(SqList &L,int i,int e)
{
// 算法2.4,在顺序线性表L中第i个位置之前插入新的元素e
// i的合法值为1≤i≤L.length +1
// 请补全代码

}

int ListDelete_Sq(SqList &L,int i, int &e)
{
// 算法2.5,在顺序线性表L中删除第i个位置的元素,并用e返回其值
// i的合法值为1≤i≤L.length
// 请补全代码

}

int main()
{
SqList T;
int a, i;
ElemType e, x;
if() // 判断顺序表是否创建成功
{
printf(“A Sequence List Has Created.\n”);
}
while(1)
{
printf(“1:Insert element\n2:Delete element\n3:Load all elements\n0:Exit\nPlease choose:\n”);
scanf(“%d”,&a);
switch(a)
{
case 1: scanf(“%d%d”,&i,&x);
if(
) printf(“Insert Error!\n”); // 执行插入函数,根据返回值判断i值是否合法
else printf(“The Element %d is Successfully Inserted!\n”, x);
break;
case 2: scanf(“%d”,&i);
if(_________________________) printf(“Delete Error!\n”); // 执行删除函数,根据返回值判断i值是否合法
else printf(“The Element %d is Successfully Deleted!\n”, e);
break;
case 3: Load_Sq(T);
break;
case 0: return 1;
}
}
}

输入格式
测试样例格式说明:
根据菜单操作:
1、输入1,表示要实现插入操作,紧跟着要输入插入的位置和元素,用空格分开
2、输入2,表示要实现删除操作,紧跟着要输入删除的位置
3、输入3,表示要输出顺序表的所有元素
4、输入0,表示程序结束

输入样例
1
1 2
1
1 3
2
1
3
0

输出样例
A Sequence List Has Created.
1:Insert element
2:Delete element
3:Load all elements
0:Exit
Please choose:
The Element 2 is Successfully Inserted!
1:Insert element
2:Delete element
3:Load all elements
0:Exit
Please choose:
The Element 3 is Successfully Inserted!
1:Insert element
2:Delete element
3:Load all elements
0:Exit
Please choose:
The Element 3 is Successfully Deleted!
1:Insert element
2:Delete element
3:Load all elements
0:Exit
Please choose:
The List is: 2
1:Insert element
2:Delete element
3:Load all elements
0:Exit
Please choose:

#include <malloc.h>
#include <stdio.h>
#define OK 1
#define ERROR 0
#define LIST_INIT_SIZE 100
#define LISTINCREMENT 10
#define ElemType int
 
typedef struct
{
	int *elem; //单元数据?
	int length;
	int listsize;
} SqList;
 
int InitList_Sq(SqList &L) //形参包含了线性表的地址
{
	// 算法2.3,构造一个空的线性表L,该线性表预定义大小为LIST_INIT_SIZE
	// 请补全代码
	L.elem=new ElemType[LIST_INIT_SIZE];
    if(!L.elem) return ERROR;
    L.length=0;
    return OK;
	/*SqList *pbase = &L;										   //创建一个指针装着首地址
	pbase->elem = (int *)malloc(sizeof(int) * LIST_INIT_SIZE); //这里是(int *)malloc 不是(SqList *) 因为人家是给elem分配空间 elem是int类型
	pbase->listsize = LIST_INIT_SIZE;
	pbase->length = 0;
	return OK;*/
}
 
int Load_Sq(SqList &L)
{
	// 输出顺序表中的所有元素
	int i;
	if (L.length == 0)
		printf("The List is empty!"); // 请填空
	else
	{
		printf("The List is: ");
		for (i = 0; i < L.length; i++)
			printf("%d ", L.elem[i]); // 请填空
	}
	printf("\n");
	return OK;
}
 
int ListInsert_Sq(SqList &L, int i, int e)
{
	// 算法2.4,在顺序线性表L中第i个位置之前插入新的元素e
	// i的合法值为1≤i≤L.length +1
	// 请补全代码
	int a;
	if (i < 1 || i > L.length + 1)
		return ERROR;
	else
	{
		for (a = L.length; a >= i; a--) //  4 5 6 7 [] 插入在第三个插入  list[4]=list[3]  list[3]=list[2]
			L.elem[a] = L.elem[a - 1];	// 序号  0 1 2 3 4
		L.elem[i - 1] = e;
		L.length++;
		return OK;
	}
}
 
int ListDelete_Sq(SqList &L, int i, int &e)
{
	// 算法2.5,在顺序线性表L中删除第i个位置的元素,并用e返回其值
	// i的合法值为1≤i≤L.length
	// 请补全代码
	int a;
	if (i < 1 || i > L.length)
		return ERROR;
	else
	{
		e = L.elem[i - 1];		//先把被删的项目存起来
		for (a =i - 1; a <= i; a++)         // 2 5 1 2 6  删除第三个 list[2]=a[3],  list[3]=a[4] a要小于等于i
			L.elem[a ] = L.elem[a+1];	// 序号 0 1 2 3 4
		L.elem[L.length - 1] = NULL;
		L.length--;
		return OK;
	}
}
 
int main()
{
	SqList T;
	int a, i;
	ElemType e, x;
	if (InitList_Sq(T)) // 判断顺序表是否创建成功
	{
		printf("A Sequence List Has Created.\n");
	}
	while (1)
	{
		printf("1:Insert element\n2:Delete element\n3:Load all elements\n0:Exit\nPlease choose:\n");
		scanf("%d", &a);
		switch (a)
		{
		case 1:
			scanf("%d%d", &i, &x);
			if (ListInsert_Sq(T, i, x)==ERROR) //Sb实验判断 注意
				printf("Insert Error!\n"); // 判断i值是否合法,请填空
			else
				printf("The Element %d is Successfully Inserted!\n", x);
			break;
		case 2:
			scanf("%d", &i);
			if (ListDelete_Sq(T, i, e)==ERROR)
				printf("Delete Error!\n"); // 判断i值是否合法,请填空
			else
				printf("The Element %d is Successfully Deleted!\n", e);
			break;
		case 3:
			Load_Sq(T);
			break;
		case 0:
			return 1; //结束程序
		}
	}
}
  • 3
    点赞
  • 14
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值