hdu 3635



Dragon Balls

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5707    Accepted Submission(s): 2117


Problem Description
Five hundred years later, the number of dragon balls will increase unexpectedly, so it's too difficult for Monkey King(WuKong) to gather all of the dragon balls together.

His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities' dragon ball(s) would be transported to other cities. To save physical strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls.
Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the ball has been transported so far.
 

Input
The first line of the input is a single positive integer T(0 < T <= 100).
For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000).
Each of the following Q lines contains either a fact or a question as the follow format:
  T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different.
  Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)
 

Output
For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.
 

Sample Input
  
  
2 3 3 T 1 2 T 3 2 Q 2 3 4 T 1 2 Q 1 T 1 3 Q 1
 

Sample Output
  
  
Case 1: 2 3 0 Case 2: 2 2 1 3 3 2
 
如果直接暴力肯定会超时,所以采用树状数组维护,主要需要注意的地方在于查找次数的时候,只需要在合并的时候将被移动的节点次数++,查找的时候加上父节点移动的次数就行了。
这道题还有一个坑在于只能用scanf和printf,不然也会超时,就因为这点TLE了好多次……所以以后在hdu打还是少用cin和cout……

#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include<string>
#include<vector>
#include<string.h>

using namespace std;

int f[10010];
int num[10010];
int times[10010];
int find(int x){
    if(x==f[x])return x;
    int t=f[x];
    f[x]=find(f[x]);
    times[x]+=times[t];
    return f[x];
}
void Union(int a,int b){
    int x=find(a);
    int y=find(b);
    if(x==y)return;
    f[x]=y;
    num[y]+=num[x];
    times[x]++;
}

int main(){
#ifdef LOCAL
	freopen("in.txt","r",stdin);
	freopen("out.txt","w",stdout);
#endif
    int T;
    cin>>T;
    int Case=0;
    while(T--){
        Case++;
		int a,b;
        cout<<"Case "<<Case<<":"<<endl;
        int n,m;
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++){
            f[i]=i;
            num[i]=1;
            times[i]=0;
        }
        for(int i=0;i<m;i++){
            char c[10];
            scanf("%s",&c);
            if(c[0]=='T'){
                scanf("%d%d",&a,&b);
                Union(a,b);
            }
            else {
                scanf("%d",&a);
                int x=find(a);
                printf("%d %d %d\n",x,num[x],times[a]);
            }
        }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值