hdu-3635 Dragon Balls(并查集)

Dragon Balls

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11845 Accepted Submission(s): 4137

Problem Description
Five hundred years later, the number of dragon balls will increase unexpectedly, so it’s too difficult for Monkey King(WuKong) to gather all of the dragon balls together.
在这里插入图片描述

His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities’ dragon ball(s) would be transported to other cities. To save physical strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls.
Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the ball has been transported so far.

Input
The first line of the input is a single positive integer T(0 < T <= 100).
For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000).
Each of the following Q lines contains either a fact or a question as the follow format:
T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different.
Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)

Output
For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.

Sample Input

2
3 3
T 1 2
T 3 2
Q 2
3 4
T 1 2
Q 1
T 1 3
Q 1

Sample Output

Case 1:
2 3 0
Case 2:
2 2 1
3 3 2

分析

主要在于记录移动次数,移动次数就是自己的移动次数来加上父节点的移动次数。

代码

#include<iostream>
using namespace std;
const int maxn=10005;
int s[maxn];
int cnt[maxn];
int num[maxn];
void init_set(int n)
{
	for(int i=1;i<=n;i++){
		s[i]=i;
		cnt[i]=1;
		num[i]=0;
	}
}
int find_set(int x)
{
	if(x==s[x]) return x;
	int t=s[x];
	s[x]=find_set(s[x]);
	num[x]+=num[t];
	return s[x];
}
void union_set(int x,int y)
{
	x=find_set(x);
	y=find_set(y);
	if(x!=y){
		s[x]=y;
		cnt[y]+=cnt[x];
		num[x]=1;
	}
}
int main()
{
//	freopen("data.txt","r",stdin);
	int t,n,q;
	char ch;
	int Case=1;
	cin>>t;
	while(t--){
		int first=1;
		scanf("%d %d",&n,&q);
		getchar();
		init_set(n);
		
		while(q--){
		cin>>ch;
		
		if(ch=='T'){
			int x,y;
			scanf("%d %d",&x,&y);
			getchar();
			union_set(x,y);
		}
		else if(ch=='Q'){
			int city;
			scanf("%d",&city);
			getchar();
			if(first) printf("Case %d:\n",Case);
			int f=find_set(city);
			printf("%d %d %d\n",f,cnt[f],num[city]);
			first=0;
		}
	  }
	  Case++;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值