hdu 2838



Problem Description
Sherlock's N (1 ≤ N ≤ 100,000) cows are lined up to be milked in the evening. Each cow has a unique "grumpiness" level in the range 1...100,000. Since grumpy cows are more likely to damage Sherlock's milking equipment, Sherlock would like to reorder the cows in line so they are lined up in increasing order of grumpiness. During this process, the places of any two cows (necessarily adjacent) can be interchanged. Since grumpy cows are harder to move, it takes Sherlock a total of X + Y units of time to exchange two cows whose grumpiness levels are X and Y.

Please help Sherlock calculate the minimal time required to reorder the cows.
 

Input
Line 1: A single integer: N
Lines 2..N + 1: Each line contains a single integer: line i + 1 describes the grumpiness of cow i.
 

Output
Line 1: A single line with the minimal time required to reorder the cows in increasing order of grumpiness.
 

Sample Input
  
  
3 2 3 1
 

Sample Output
  
  
7
Hint
Input Details Three cows are standing in line with respective grumpiness levels 2, 3, and 1. Output Details 2 3 1 : Initial order. 2 1 3 : After interchanging cows with grumpiness 3 and 1 (time=1+3=4). 1 2 3 : After interchanging cows with grumpiness 1 and 2 (time=2+1=3).
 
题意:这题其实还挺好理解的,就是看每个数t之前有多少个比他大的数(设为x),然后用比他大的数的和sum加上x*t,所以很明显要用树状数组来做。
           纠结了好久的树状数组怎么更新和维护,看了别人的博客之后大概懂了一点。

#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include<string>
#include<vector>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
long long ans[100010];
long long Count[100010];
long long n;
void join(long long k,long long num){
	while(k<=n){
		ans[k]+=num;
		Count[k]+=1;
		k+=k&-k;
	}
}
long long Sum(long long k){
	long long sum=0;
	while(k){
		sum+=ans[k];
		k-=k&-k;
	}
	return sum;
}
long long Sum_count(long long k){
	long long sum=0;
	while(k){
		sum+=Count[k];
		k-=k&-k;
	}
	return sum;
}
int main(){
#ifdef LOCAL
	freopen("in.txt","r",stdin);
	freopen("out.txt","w",stdout);
#endif
	memset(ans,0,sizeof(ans));
	while(scanf("%d",&n)!=EOF){
		long long res=0;
		for(int i=1;i<=n;i++){
			long long temp;
			scanf("%lld",&temp);
			join(temp,temp);
			long long k1=i-Sum_count(temp);//到此为止  比x大的个数;  
			///sum_count[x] 为输入i个数的时候 x之前有sum_count[x]个比x小的数 用i相减则为大于x的个数
			if(k1!=0){
				long long k2=Sum(n)-Sum(temp);//Sum(n)-Sum(temp)为到当前为止比这个数大的所有数之和。
				res+=k1*temp+k2;
			}
		}
		printf("%lld\n",res);
	}
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值