hdu 2838(树状数组求逆序数)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2838

Cow Sorting

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2382    Accepted Submission(s): 766


Problem Description
Sherlock's N (1 ≤ N ≤ 100,000) cows are lined up to be milked in the evening. Each cow has a unique "grumpiness" level in the range 1...100,000. Since grumpy cows are more likely to damage Sherlock's milking equipment, Sherlock would like to reorder the cows in line so they are lined up in increasing order of grumpiness. During this process, the places of any two cows (necessarily adjacent) can be interchanged. Since grumpy cows are harder to move, it takes Sherlock a total of X + Y units of time to exchange two cows whose grumpiness levels are X and Y.

Please help Sherlock calculate the minimal time required to reorder the cows.
 

Input
Line 1: A single integer: N
Lines 2..N + 1: Each line contains a single integer: line i + 1 describes the grumpiness of cow i.
 

Output
Line 1: A single line with the minimal time required to reorder the cows in increasing order of grumpiness.
 

Sample Input
  
  
3 2 3 1
 

Sample Output
  
  
7
Hint
Input Details Three cows are standing in line with respective grumpiness levels 2, 3, and 1. Output Details 2 3 1 : Initial order. 2 1 3 : After interchanging cows with grumpiness 3 and 1 (time=1+3=4). 1 2 3 : After interchanging cows with grumpiness 1 and 2 (time=2+1=3).
 

Source
思路: eg:  4 5 3 2 1  我们可以观察到第三个数 的rank值是3,那么在这个数的左边有 两个比它大的数,说明第三个数至少得和左边的数交换2次 ~~

           so ~    设一个数a左边有k个比他大的数  并且这k个数的和是sum,  那么交换代价是 cnt=k*a+sum;对吧~所以遍历一遍即可,(用树状数组加速,可以用来求逆序数)

    

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <cstdio>
#include <cmath>
typedef long long ll;
const int N=1e5+100;
using namespace std;

ll c[N];  
ll index[N]; 
ll a[N];
int n;

int lowbit(int x)
{
    return x&(-x);
}

void update(int x,int d)
{
  while(x<=n)
  {
    c[x]+=d;
    index[x]+=1;
    x+=lowbit(x);
  }
}

ll get_sum(int x)
{
 ll ans=0;
 while(x>0)
 {
   ans+=c[x];
   x-=lowbit(x);
 }
 return ans;
}

ll get_index(int x)
{
  ll ans=0;
  while(x>0)
  {
    ans+=index[x];
    x-=lowbit(x);
  }
  return ans;
}
void Init()
{
  for(int i=1;i<=n;i++)scanf("%I64d",&a[i]);
  memset(c,0,sizeof(c));
  memset(index,0,sizeof(index));

}
int main()
{
        while(scanf("%d",&n)!=EOF)
        {
          Init();
          ll cnt=0;
          for(int i=1;i<=n;i++)
          {
            update(a[i],a[i]);
            ll k=i-get_index(a[i]);
            if(k)
            {
             cnt+=k*a[i];
             cnt+=get_sum(n)-get_sum(a[i]);
            }
          }
          printf("%I64d\n",cnt);
        }
        return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值