POJ 2002 Squares 求正方形的个数,点哈希

Squares
Time Limit: 3500MS Memory Limit: 65536K
Total Submissions: 18426 Accepted: 7086

Description

A square is a 4-sided polygon whose sides have equal length and adjacent sides form 90-degree angles. It is also a polygon such that rotating about its centre by 90 degrees gives the same polygon. It is not the only polygon with the latter property, however, as a regular octagon also has this property. 

So we all know what a square looks like, but can we find all possible squares that can be formed from a set of stars in a night sky? To make the problem easier, we will assume that the night sky is a 2-dimensional plane, and each star is specified by its x and y coordinates. 

Input

The input consists of a number of test cases. Each test case starts with the integer n (1 <= n <= 1000) indicating the number of points to follow. Each of the next n lines specify the x and y coordinates (two integers) of each point. You may assume that the points are distinct and the magnitudes of the coordinates are less than 20000. The input is terminated when n = 0.

Output

For each test case, print on a line the number of squares one can form from the given stars.

Sample Input

4
1 0
0 1
1 1
0 0
9
0 0
1 0
2 0
0 2
1 2
2 2
0 1
1 1
2 1
4
-2 5
3 7
0 0
5 2
0

Sample Output

1
6
1

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string.h>
#include <algorithm>
using namespace std;

const int N = 1005;
const int H = 10000+5;
struct Point {
	int x,y;
} p[N];

struct Node {
	int x,y;
	int next;
} node[N];

int cnt,n;
__int64 ans;
int hash[H];

void initial(){
	for(int i=0;i<H;i++){
		hash[i] = -1;
	}
//	cur = ans = 0;
}
// initial: hash[h] = -1;
// Then: hash[h] = cnt; && node[cnt].next = hash[h];
// hash[h] is defined as a head of a hash list;
// we search the hash list via the node[cnt].next;
void Insert(int x,int y){
	int h = (x*x + y*y) % H;
	node[cnt].x = x;
	node[cnt].y = y;
	node[cnt].next = hash[h];
	hash[h] = cnt ++;
}

bool search(int x,int y){
	int h = (x*x + y*y) % H;
	int t = hash[h];
	
	while(t!=-1){
		if(x==node[t].x && y==node[t].y) return true;
		else t = node[t].next;
	}
	return false;
}
/* 
已知:	(x1,y1)  (x2,y2)

则:	x3=x1+(y1-y2)   y3= y1-(x1-x2)
		x4=x2+(y1-y2)   y4= y2-(x1-x2)

或		x3=x1-(y1-y2)   y3= y1+(x1-x2)
		x4=x2-(y1-y2)   y4= y2+(x1-x2)
*/
void deal(){
	int i,j;
	
	for(i=0;i<n;i++){
		for(j=i+1;j<n;j++){
			int x1 = p[i].x - (p[i].y - p[j].y);
			int y1 = p[i].y + (p[i].x - p[j].x);
			int x2 = p[j].x - (p[i].y - p[j].y);
			int y2 = p[j].y + (p[i].x - p[j].x);
			
			if(search(x1,y1) && search(x2,y2)) ans++;
			
			x1 = p[i].x + (p[i].y - p[j].y);
			y1 = p[i].y - (p[i].x - p[j].x);
			x2 = p[j].x + (p[i].y - p[j].y);
			y2 = p[j].y - (p[i].x - p[j].x);
			
			if(search(x1,y1) && search(x2,y2)) ans++;
		}
	}
	ans>>=2;
}


int main(){
	
	while(~scanf("%d",&n),n){
		initial();
		cnt = ans = 0;
		for(int i=0;i<n;i++){
			scanf("%d%d",&p[i].x,&p[i].y);
			Insert(p[i].x,p[i].y);
		}
		deal();
		printf("%I64d\n",ans);
	}
	
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值