poj 2202 Squares(求正方形个数)

9 篇文章 0 订阅
5 篇文章 0 订阅
这篇博客详细解析了ACM竞赛中POJ 2202题目的解题思路,主要探讨如何计算平面内不同大小的正方形个数。适合ACM参赛者和算法爱好者阅读。
摘要由CSDN通过智能技术生成
Squares
Time Limit: 3500MS Memory Limit: 65536K
Total Submissions: 18162 Accepted: 6969
Description


A square is a 4-sided polygon whose sides have equal length and adjacent sides form 90-degree angles. It is also a polygon such that rotating about its centre by 90 degrees gives the same polygon. It is not the only polygon with the latter property, however, as a regular octagon also has this property. 


So we all know what a square looks like, but can we find all possible squares that can be formed from a set of stars in a night sky? To make the problem easier, we will assume that the night sky is a 2-dimensional plane, and each star is specified by its x and y coordinates. 
Input


The input consists of a number of test cases. Each test case starts with the integer n (1 <= n <= 1000) indicating the number of points to follow. Each of the next n lines specify the x and y coordinates (two integers) of each point. You may assume that the points are distinct and the magnitudes of the coordinates are less than 20000. The input is terminated when n = 0.
Output


For each test case, print on a line the number of squares one can form from the given stars.
Sample Input


4
1 0
0 1
1 1
0 0
9
0 0
1 0
2 0
0 2
1 2
2 2
0 1
1 1
2 1
4
-2 5
3 7
0 0
5 2
0
Sample Output


1
6

1

#include <cstdio>
#include <cstring>
#include<algorithm>
#include <cmath>
#include <vector>
using namespace std;
#define N 1000
int n;
struct node {
	int x;
	int y;
}point[N];
bool cmp(node a, node b)
{
	return (a.x < b.x || (a.x == b.x && a.y < b.y));
}
int bsearch(int x, int y)
{
	int	mid, l = 0, r = n - 1;
	while (l <= r) {
		mid = (l + r) / 2;
		if (point[mid].x == x && point[mid].y == y) return 1;
		if (point[mid].x > x || (point[mid].x == x && point[mid].y > y)) {
			r = mid - 1;
		}
		else {
			l = mid + 1;
		}
	}
	return 0;
}
int main()
{
	int x, y, i, j, count;
	while (scanf("%d", &n)&&n)
	{
		count = 0;
		for (i = 0; i < n; i++)
			scanf("%d %d", &point[i].x, &point[i].y);
		sort(point, point + n, cmp);
		for (i = 0; i < n; i++) {
			for (j = (i + 1); j < n; j++) {
				x = point[i].y - point[j].y + point[i].x;
				y = point[j].x - point[i].x + point[i].y;
				if (bsearch(x, y) == 0) {
					continue;
				}
				x = point[i].y - point[j].y + point[j].x;
				y = point[j].x - point[i].x + point[j].y;
				if (bsearch(x, y)) {
					count++;
				}
			}
		}
		printf("%d\n", count / 2);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值