ZOJ Problem Set - 3777

http://www.icpc.moe/onlinejudge/showProblem.do?problemId=5264

Problem Arrangement


Time Limit: 2 Seconds       Memory Limit: 65536 KB

The 11th Zhejiang Provincial Collegiate Programming Contest is coming! As a problem setter, Edward is going to arrange the order of the problems. As we know, the arrangement will have a great effect on the result of the contest. For example, it will take more time to finish the first problem if the easiest problem hides in the middle of the problem list.

There are N problems in the contest. Certainly, it's not interesting if the problems are sorted in the order of increasing difficulty. Edward decides to arrange the problems in a different way. After a careful study, he found out that the i-th problem placed in the j-th position will add Pij points of "interesting value" to the contest.

Edward wrote a program which can generate a random permutation of the problems. If the total interesting value of a permutation is larger than or equal to M points, the permutation is acceptable. Edward wants to know the expected times of generation needed to obtain the first acceptable permutation.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains two integers N (1 <= N <= 12) and M (1 <= M <= 500).

The next N lines, each line contains N integers. The j-th integer in the i-th line is Pij (0 <= Pij <= 100).

Output

For each test case, output the expected times in the form of irreducible fraction. An irreducible fraction is a fraction in which the numerator and denominator are positive integers and have no other common divisors than 1. If it is impossible to get an acceptable permutation, output "No solution" instead.

Sample Input
2
3 10
2 4 1
3 2 2
4 5 3
2 6
1 3
2 4
Sample Output
3/1
No solution

#include <iostream>
#include <cstring>
#include <string>
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <vector>
#include <bitset>
#include <queue>
#include <map>

using namespace std;

//状态压缩DP
const int N = 13;
int dp[1<<13][510];
int f[N];
int a[N][N];

int gcd (int a,int b){
    if(b==0) return a;
    return gcd(b,a%b);
}

void initial()
{
    f[1] = 1;
    for(int i=2;i<N;i++){
        f[i] = f[i-1]*i;
    }
}

int main(){
    int i,j,k,t,m,n;
   // cout<<"adding "<<(1<<12)<<endl;
    scanf("%d",&t);
    initial();
    while(t--)
    {
        scanf("%d%d",&n,&m);

    //一定要从1开始
        for(int i=1;i<=n;i++){
            for(int j=1;j<=n;j++){
                scanf("%d",&a[i][j]);
            }
        }
        memset(dp,0,sizeof(dp));
        dp[0][0] = 1;
      //  cout<<"test point 1"<< (1<<n) <<endl;
        // 1 本来就有一位了,再左移n位就到了n+1位上面,到时候-1就是一个
        // 从1-n 位都是 1 的数了。
        int tot = (1<<n);
        for(int i=0;i<tot;i++){
            int cnt = 0;
            // 逐位比较,看看哪位是 1
            for(int j=1;j<=n;j++){
                if(i&(1<<(j-1))) cnt ++;
            }
          //  cout<<"test point 2 "<<cnt<<' '<<endl;

            for(int j=1;j<=n;j++){
                if(i&(1<<(j-1))) continue;   //
                for(int k=0;k<=m;k++){
                    if(k+a[cnt+1][j] >=m ){  // 这是为了节省空间
                        dp[i+(1<<(j-1))][m] += dp[i][k];
                    }
                    else{
                        dp[i+(1<<(j-1))][k+a[cnt+1][j]] += dp[i][k];
                    }
                }
            }
        }
        if(dp[(1<<n)-1][m] == 0)
            cout<<"No solution"<<endl;
        else{
            int ha = gcd(f[n],dp[(1<<n)-1][m]);
            printf("%d/%d\n",f[n]/ha,dp[(1<<n)-1][m]/ha);
        }

    }

    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值