HDU 1005 Number Sequence

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 114142    Accepted Submission(s): 27730


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
  
  
1 1 3 1 2 10 0 0 0
 

Sample Output
  
  
2 5
 


题目意思很好理解,如果直接进行计算是会超时的,不过注意到f[i]mod 7 之后的值只能是0 - 6之中的一个值,也就是7个不同的数,又由该关系式得知每一项只与前两项发生关系,所以当连续的两项在前面出现过,则以后就一定是循环,7个数中任意取两个组成不同数对,那么最多可能数为A(7, 2)  + 7 = 49种不同的组合,所以到最坏情况下到f[49],f[50]时一定会发生重复前面相邻两个元素序列的情况,所以最坏情况下的循环节就是49及f[1]-f[48],所以可以把n mod 49,当然若结果为0, 表示已经转过到下一个循环了,所以可以使其为1,即下个循环的首个元素,ok,原理讲清楚 ,下面是代码。

 

#include<iostream>

using namespace std;

const int N = 55;
int res[N];

void func(int a, int b){
	res[1] = res[2] = 1;
	
	//printf("1\t1\t");

	for (int i = 3; i <= N; i++)
	{
		res[i] = (a*res[i - 1] + b*res[i - 2]) % 7;
		//printf("%d\t", res[i]);
	}
}
int main(){
	int a, b, n;
	while (scanf("%d %d %d", &a, &b, &n))
	{
		if (a == 0 && b == 0 && n == 0)break;
		func(a, b);

		n %= 49;
		if (n == 0)n = 1;
		printf("%d\n", res[n]);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值