A/B
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 6257 Accepted Submission(s): 4935
Problem Description
要求(A/B)%9973,但由于A很大,我们只给出n(n=A%9973)(我们给定的A必能被B整除,且gcd(B,9973) = 1)。
Input
数据的第一行是一个T,表示有T组数据。
每组数据有两个数n(0 <= n < 9973)和B(1 <= B <= 10^9)。
每组数据有两个数n(0 <= n < 9973)和B(1 <= B <= 10^9)。
Output
对应每组数据输出(A/B)%9973。
Sample Input
2 1000 53 87 123456789
Sample Output
7922 6060
思路: n = A%9973
n = A - A/9973*9973;
设 : A/B = x;
A = Bx;
代入 : Bx - A/9973*9973 = n;
令 : y = A/9973
得 : Bx - 9973y = n ;
除 n 得 : Bx/n - 9973y/n = 1 = GCD( B , 9973 ) = Bx1 + 9973y1 = 1;
x1 = x/n , y1 = y/n;
使用扩展欧几里得算法可求得 x1,y1的值,x = x1 * n;
代码:
#include<stdio.h>
int x,y;
void gcd(int a,int b)
{
int t;
if(b==0)
{
x=1;
y=0;
return ;
}
gcd(b,a%b);
t=x;
x=y;
y = t - (a/b)*y;
return ;
}
int main()
{
long long n,b;
int t;
scanf("%d",&t);
while(t--)
{
scanf("%lld%lld",&n,&b);
gcd(b,9973);
if(x<0)//防止x小于0;
x+=9973;
x*=n;
printf("%d\n",x%9973);
}
return 0;
}