HDU - 1514 Stars

题面

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.
在这里插入图片描述

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it’s formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

题目大意

给定n颗星星的位置,让你计算各个等级(从0级到n-1级)的星星的个数。星星的等级的定义是:以它本身为原点建立坐标轴,第三象限星星的个数加上x和y负半轴上的星星的个数。星星的位置不重复。输入的星星以y坐标升序输入。

题目分析

注意到输入的特点,以y轴坐标升序输入。也就是说,输入保证了后面的星星不在前面星星的第三象限。也就是,每当输入一个星星,我们只需要计算一下前面比它x坐标小的星星的个数就行了。问题就转化成了怎么去计算前面比它x坐标小的星星个数呢?不用问,遍历一遍肯定是会超时的,这样造成了过多的重复计算。我们需要一个能快速求和的工具,我首先想到的是前缀和。但是前缀和有个很大的问题,就是单点修改会慢。那么能快速求和又能单点修改的最合适的就是树状数组了。

那么怎么计算呢?我们以样例来举例。

当输入第一个坐标(1,1)的时候,数组(这不是树状数组的值)的内部是这样的,在输入更改这个数组之前,先求和一下位置1以及之前的星星的个数,然后填进等级统计数组当中。

数组位置12345
数组的值10000
等级统计数组01234
数组的值10000

输入第二个坐标(5,1)的时候,一样先统计一下在它之前的星星的个数。

数组位置12345
数组的值10001
等级统计数组01234
数组的值11000

第三个坐标(7,1)的时候:

数组位置1234567
数组的值1000101
等级统计数组01234
数组的值11100

第四个坐标(3,3)的时候:

数组位置1234567
数组的值1010101
等级统计数组01234
数组的值12100

后面的以此类推,在放进数组之前统计一下在此之前的星星的个数,保存下来即可.
注意一下树状数组的位置0是不能用的,会陷阱死循环。

代码

#include <cstdio>
using namespace std;
const int maxn = 1e5;
int a[32005], b[32005];
int n;
int lowbit(int n){
  return n & (n ^ (n - 1));
}

void add(int x, int k)
{
    for (int i = x; i <= 32005; i += lowbit(i))
        a[i] += k;
}

int sum(int x)
{
    int ans = 0;
    for (int i = x; i; i -= lowbit(i))
        ans += a[i];
    return ans;
}
int main(int argc, char const *argv[]) {
  scanf("%d", &n);
  for(int i = 0; i < n; i++){
    int x, y;
    scanf("%d%d", &x, &y);
    b[sum(x + 1)]++;
    add(x + 1, 1);
  }
  for(int i = 0; i < n; i++)
    printf("%d\n", b[i]);
  return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值