HDU - 1051 Wooden Sticks【LIS】

Wooden Sticks

传送门

题目

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:

(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l’ and weight w’ if l<=l’ and w<=w’. Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).

Input:

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, …, ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

Output:

The output should contain the minimum setup time in minutes, one per line.

Sample Input:

3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1

Sample Output:

2
1
3

题目大意

有一堆木棍。已知每根杆的长度和重量。这些木棍将由木工机器逐一加工。它需要一些时间,称为设置时间,以便机器准备处理棒。设置时间与清洁操作以及更换机器中的工具和形状相关联。木工机器的安装时间如下:

(a)第一根木棍的安装时间为1分钟。
(b)在加工长度为l且重量为w的棒之后,如果l <= l’且w<= w’(下一根需要加工的木棒长l’重w’),则机器将不需要设置长度l’和重量w’的设定时间。否则,需要1分钟进行设置。

你要找到处理一堆n根木棍的最短安装时间。例如,如果你有五根长度和重量对分别为(4,9),(5,2),(2,1),(3,5)和(1,4),那么最小设置时间应该是2分钟,因为有一组(1,4),(3,5),(4,9),(2,1),(5,2)的加工序列。

分析

有点像最长上升子序列,但是这里的木棍是无序的。注意到有两个变量l,w都上升,那么我们不妨先固定l是上升的,也就是以l为权重排序,再对w使用最长上升子序列就可以了。

参考代码

#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <iostream>
#include <algorithm>
#ifdef LOCAL
#define frein(x) freopen(x, "r", stdin)
#define freout(x) freopen(x, "w", stdout)
#else
#define frein(x)
#define freout(x)
#define squ(x) ((x) * (x))
#endif
#define mem(x, v)  memset(x, v, sizeof(x))
using namespace std;
typedef long long ll;
const int maxn = 1e5 + 7;
const int inf = 0x3f3f3f3f;
typedef struct node{
    int x, y;
    bool operator < (const node &b) const{
        if(x == b.x)
            return y < b.y;
        else
            return x < b.x;
    }
}node;
node arr[maxn];
int dp[maxn];
int main(void){
    frein("data.in");
    //freout("data.out");
    int T; cin >> T;
    while(T--){
        int n; cin >> n;
        for(int i = 0; i < n; i++){
            scanf("%d%d", &arr[i].x, &arr[i].y);
        }
        sort(arr, arr + n);
        for(int i = 0; i < n; i++)
            dp[i] = 1;
        for(int i = 1; i < n; i++){
            for(int j = 0; j < i; j++){
                if(arr[j].y > arr[i].y){
                    dp[i] = max(dp[i], dp[j] + 1);
                }
            }
        }
        int ans = -1;
        for(int i = 0; i < n; i++){
            ans = max(ans, dp[i]);
        }
        printf("%d\n", ans);
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值