HDOJ1003

/*Problem Description
Given a sequence a[1],a[2],a[3]......a[n],
your job is to calculate the max sum of a sub-sequence.
For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 
Input
The first line of the input contains an integer T(1<=T<=20)
which means the number of test cases.
Then T lines follow, each line starts with a number N(1<=N<=100000),
then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

 

Sample Output

Case 1:
14 1 4

Case 2:
7 1 6*/
//一开始有些看不懂题意,看起来并不是求最大子序列呀
//搜了题解之后懂了,原来每一行前面要输入数组大小
//动态规划
#include<iostream>
using namespace std;
int main(){
    int T,N,sum,start,end,max; int temp=1;
    int dp;
    cin>>T;
    for(int k=0;k<T;k++){
        cin>>N; temp=1;
    /*    dp= new int[N+1];
        for(int i=0;i<N;i++) cin>>dp[i];
        max=dp[0];
        for(start=0;start<N;start++){
            sum=dp[start];
            for(end=start+1;end<N;end++){
                sum+=dp[end];
                if(max<sum){//一开始我把If放在外面我发现自己每次都是重新加的,其实应该加一下判断一下
                    max=sum; f=start; l=end;
                }
            }
        }
        
        delete []dp;*/
        //开始想的是把start从0开始往end加,有Max就记下下标,然后输出最大的下标,时间复杂度为n^3 /结果发现超时了,毕竟是n3啊
        max=-1001; sum=0; // start=1;
        for(int i=0;i<N;i++){
            cin>>dp;
            sum+=dp;
            if(sum>max){
                max=sum; start=temp; end=i+1;
            }
            if(sum<0){
                sum=0;如果总数比0小,说明刚刚加的数字应该舍去,所以更新temp,temp更新start
                temp=i+2;
            }
        }
        cout<<"Case "<<k+1<<":"<<endl;
        cout<<max<<" "<<start<<" "<<end<<endl;    
        //参考了别人的算法
        if(k!=T-1) cout<<endl;
    }
     //如果全是负数,最大值为0,因为有一段子序列为空集
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值