【PAT甲级】1002 A+B for Polynomials (25 分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N1 aN1 N2 aN2 ... Nk aNk

where K is the number of nonzero terms in the polynomial, Ni and aNi
​​ 
​​  (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K<⋯<N​2<N1≤1000.

Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output:
3 2 1.5 1 2.9 0 3.2

【翻译】:计算多项式的和,每个样例有两行,每一行代表一个多项式,K是非零整数,Ni是指数,aNi是系数,K范围是1到10,NK范围是0到1000,输出一行,行尾不可有空格

举栗说明:

2 1 2.4 0 3.2表示 多项式有两个项,分别是指数为1,系数为2.4和指数为0系数为3.2的项。

这题肥肠简单了……但是有几个坑

1.系数为负数时要输出,不然测试点2过不去

2.输出要精确到小数点后一位

#include <iostream>
#include <iomanip>
using namespace std;
double a[1005];
int main(){
	int n,k,x,m,count = 0;
	double y;
	cin>>m;
	for(int i = 0; i < m; i++){
		cin>>x>>y;
		a[x] += y;
	}
	cin>>m;
	for(int i = 0; i < m; i++){
		cin>>x>>y;
		a[x] += y;
	}
	for(int i = 0; i < 1001; i++){
		if(a[i] != 0) count++;
	} 
	cout<<count;
	for(int i = 1001; i >= 0; i--){
		if(a[i] != 0){
			cout<<" "<<i<<" "<<setiosflags(ios::fixed)<<setprecision(1)<<a[i];
		}
	}
	return 0;
} 

 

  • 4
    点赞
  • 8
    收藏
    觉得还不错? 一键收藏
  • 5
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 5
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值