Tempter of the Bone (剪枝)

Tempter of the Bone

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)

Total Submission(s) : 62   Accepted Submission(s) : 15

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter;
'S': the start point of the doggie;
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.

Output

For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.

Sample Input

4 4 5
S.X.
..X.
..XD
....
3 4 5
S.X.
..X.
...D
0 0 0

Sample Output

NO
YES

这道题就是一道搜索题,经典的剪枝运用,我采用了很多剪枝如:奇偶剪枝、路径剪枝等。

什么是奇偶剪枝,就是假设这个地图的最短路线是step, 步数t = step + extra, t也就是规定的时间,因为一次一步

当temp = t - step - z; temp为奇数的时候就必定到不了终点,偶数就可以,证明过程可以百度。

路径剪枝是什么意思就是如果地图的size n * m -wall < t说明就到不了

当我搜索的过程中如果z > t那么也不必要搜索了。

当我搜索的过程中如果我起点就是终点并且z < t那么也不必要搜索了

附上ac代码:

# include <iostream>
# include <cstring>
# include <cmath>
using namespace std;
const int maxn = 10;
char str[maxn][maxn];
bool book[maxn][maxn];
int n, m, t;
int sx,sy,ex, ey;
bool flag;
int dir[][2] = {0, 1, 0, -1, 1, 0, -1, 0};

void dfs(int sx, int sy, int z)
{
    if(flag)//如果我找到了再次进来就剪掉
       return ;
	if( z >t)//如果大于z > t剪掉
        return ;
	if(sx == ex && sy == ey && z == t)
    {
        flag = true;
        return ;
    }
    if(sx == ex && sy == ey && z < t)//判断一开始是不是终点
       return ;

    int temp = t - abs(sx - ex) - abs(sy - ey) - z;
    if(temp < 0 || temp & 1)//奇偶剪枝
        return ;
    for(int i = 0; i < 4; i++)
    {
        int tx = sx + dir[i][0];
        int ty = sy + dir[i][1];
        if(tx >= 0 && tx < n && ty >= 0 && ty < m && str[tx][ty]  != 'X' && !book[tx][ty])//如果符合就进来
        {
            book[tx][ty] = true;
            dfs(tx, ty , z + 1);
            book[tx][ty] = false;
        }
    }
    return ;
}

int main(int argc, char *argv[])
{
    while(cin >> n >> m >> t && n != 0 &&(m||n||t))
    {
        int len = 0;
        flag = false;
        memset(book, false, sizeof(book));
		memset(str, false, sizeof(str));
        for(int i = 0; i < n; i++)
        {
            for(int j = 0; j < m; j++)
            {
                cin >> str[i][j];
                if(str[i][j] == 'X')
                    len++;
                if(str[i][j] == 'S')
                {
                    sx = i;
                    sy = j;
                    str[i][j] = '.';//要注意的是我起始点赋值成墙或者标记用过不然会有重复路劲
                    book[i][j] = true;
                }
                if(str[i][j] == 'D')
                {
                    ex = i;
                    ey = j;
                    str[i][j] = '.';
                }
            }
        }
        if(n*m-len>=t)//如果这个n * m - len小于t说明全走完也不可能用t时间所以剪掉
            dfs(sx,sy,0);
        if(flag)
            cout<<"YES"<<endl;
        else
            cout<<"NO"<<endl;
    }
    return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值