HDU 1213-How Many Tables(简单并查集)

How Many Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 38275    Accepted Submission(s): 19100
Problem Description
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
 

Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
 

Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
 

Sample Input
 
 
25 31 22 34 55 12 5
 
Sample Output
 
 
24
 

Author
Ignatius.L
 

Source

题目大意:一个人生日,要请他朋友吃饭,他有很多朋友,他要为他们认识的朋友准备桌子吃饭,相互认识的可以坐在一桌,不认识的分开坐,求出最小所需要的桌子数目。
解题思路:这里我们需要写一个并查集来储存他们所认识的朋友,相互认识放在一棵树上,算出树的数量即可!

AC代码:
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<math.h>
#include<time.h>
#include<map>
#include<string>
#include<algorithm>
#include<set>
#define N 1010

using namespace std;

int table[N],sum;

int formalset(int m) //初始化他们每个朋友为一棵独立的树,且树根为他们自己
{
    for(int i = 1; i <= m ;i ++)
    {
        table[i] = i;
    }
}

int findtable(int k) //查找树根(初学者一定要画图模拟!)
{
    if(table[k] != k)
        table[k] = findtable(table[k]);
    return table[k];
}

void isfriend(int a, int b) //这两个朋友认识,把他们合并同一个树根(这个请自己画图模拟一下,不然很难理解!)
{
    if(findtable(a) == findtable(b)) //是朋友并且已经合并到一起过了,直接返回
        return;
    sum --; //是朋友,没有合并,桌子数减一(开始桌子数为朋友总数)
    table[findtable(b)] = findtable(a); //b和a的根合并为a的根
}

int main()
{
    int T;
    scanf("%d", &T);
    while(T--)
    {
        int m, n, a, b;
        scanf("%d%d", &m, &n);
        sum = m;
        formalset(m);
        for(int i = 0; i < n; i ++)
        {
            scanf("%d%d", &a, &b);
            isfriend(a, b);
        }
        printf("%d\n",sum);
    }
    return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值