POJ 1042-Gone Fishing(贼恶心的贪心)

c
Time Limit: 2000MS Memory Limit: 32768K
Total Submissions: 37181 Accepted: 11546

Description

John is going on a fishing trip. He has h hours available (1 <= h <= 16), and there are n lakes in the area (2 <= n <= 25) all reachable along a single, one-way road. John starts at lake 1, but he can finish at any lake he wants. He can only travel from one lake to the next one, but he does not have to stop at any lake unless he wishes to. For each i = 1,...,n - 1, the number of 5-minute intervals it takes to travel from lake i to lake i + 1 is denoted ti (0 < ti <=192). For example, t3 = 4 means that it takes 20 minutes to travel from lake 3 to lake 4. To help plan his fishing trip, John has gathered some information about the lakes. For each lake i, the number of fish expected to be caught in the initial 5 minutes, denoted fi( fi >= 0 ), is known. Each 5 minutes of fishing decreases the number of fish expected to be caught in the next 5-minute interval by a constant rate of di (di >= 0). If the number of fish expected to be caught in an interval is less than or equal to di , there will be no more fish left in the lake in the next interval. To simplify the planning, John assumes that no one else will be fishing at the lakes to affect the number of fish he expects to catch.
Write a program to help John plan his fishing trip to maximize the number of fish expected to be caught. The number of minutes spent at each lake must be a multiple of 5.

Input

You will be given a number of cases in the input. Each case starts with a line containing n. This is followed by a line containing h. Next, there is a line of n integers specifying fi (1 <= i <=n), then a line of n integers di (1 <=i <=n), and finally, a line of n - 1 integers ti (1 <=i <=n - 1). Input is terminated by a case in which n = 0.

Output

For each test case, print the number of minutes spent at each lake, separated by commas, for the plan achieving the maximum number of fish expected to be caught (you should print the entire plan on one line even if it exceeds 80 characters). This is followed by a line containing the number of fish expected.
If multiple plans exist, choose the one that spends as long as possible at lake 1, even if no fish are expected to be caught in some intervals. If there is still a tie, choose the one that spends as long as possible at lake 2, and so on. Insert a blank line between cases.

Sample Input

2 
1 
10 1 
2 5 
2 
4 
4 
10 15 20 17 
0 3 4 3 
1 2 3 
4 
4 
10 15 50 30 
0 3 4 3 
1 2 3 
0 

Sample Output

45, 5 
Number of fish expected: 31 

240, 0, 0, 0 
Number of fish expected: 480 

115, 10, 50, 35 
Number of fish expected: 724 

Source

题目大意:一个人去钓鱼,有n个湖可以钓鱼,第i个湖的鱼的原始数量是f[i],每在i湖钓一次鱼,花费5min获得f[i]数量的鱼,i湖鱼的数量同时也会减少d[i],你有h个小时可以钓鱼,你最开始在第一个湖,同时你可以花费t[i]*5min的时间走到下一个湖,求你可以获得的最大鱼的数量,和在每个湖钓鱼花费的时间,如果数量相等,则输出在序号小的湖花费时间多的那个方案。

解题思路: 读懂题目后自己模拟了半天,还是没有思路,只是想出钓鱼是一直往后面的湖一个一个的钓,不会走回头路(干嘛要回来,浪费时间啊,还不如开始就在这里钓个够),最后还是无奈的去看题解,果然是不看题解不会做题,你只要暴力依此枚举在那个湖结束钓鱼,然后在减掉走路花费的时间,接下来就表示你可以不花费时间就在前面这几个湖随便移动了,每次选择鱼数量最大的湖钓就可以了,记录下每个湖钓鱼的时间和总数量输出即可,至于那个序号的问题,你每次都是从第一个湖开始找的,所以,一定是满足题意的,最后再把剩余的时间都加在第一个湖上即可。

AC代码: (其实我感觉你看了题解)

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<queue>
#include<math.h>
#include<string.h>
typedef long long ll;
using namespace std;
const int mod = 10;
const int N = 30;
const int INF = 1e9;

int dirx[4] = {1, 0, -1, 0};
int diry[4] = {0, 1, 0, -1};

int n, h, f[N], d[N], t[N], sumt, cost[N], idx, co, id;
int lack[N], L[N], F[N], T;

int main()
{
    while(~scanf("%d", &n)) {
        if(n == 0) break;
        scanf("%d", &h);
        int ans = 0;
        T = 0;
        co = 0;
        sumt = h*12;
        memset(cost, 0, sizeof(cost));
        memset(L, 0, sizeof(L));
        for(int i = 1; i <= n; i ++) {
            scanf("%d", &f[i]);
        }
        for(int i = 1; i <= n; i ++) {
            scanf("%d", &d[i]);
        }
        for(int i = 1; i < n; i ++) {
            scanf("%d", &t[i]);
            cost[i] = cost[i-1] + t[i];
        }
        for(int i = 1; i <= n; i ++) { //枚举在哪个湖结束钓鱼
            for(int k = 1;k <= n; k ++)
                F[k] = f[k];
            int t = sumt - cost[i-1];
            int get = 0;
            memset(lack, 0, sizeof(lack));
            while(t > 0) {
                int mm = 0;
                for(int j = 1; j <= i; j ++) {
                    if(F[j] > mm) {
                        idx = j;
                        mm = F[j];
                    }
                }
                if(mm > 0) {
                    lack[idx] ++;
                    F[idx] -= d[idx];
                    get += mm;
                }
                t --;
            }
            if(get > ans) { //更新鱼的数量
                co = cost[i-1];
                ans = get;
                T = 0;
                for(int i = 1; i <= n; i ++) {
                    L[i] = lack[i];
                    T += L[i];
                }
            }
        }
        printf("%d", ((sumt-T)+L[1]-co)*5);
        for(int i = 2; i <= n; i ++)
            printf(", %d", L[i]*5);
        printf("\nNumber of fish expected: %d\n\n", ans);
    }
    return 0;
}

  • 0
    点赞
  • 5
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
### 支持向量机非线性回归通用MATLAB程序解析 #### 一、概述 本文将详细介绍一个基于MATLAB的支持向量机(SVM)非线性回归的通用程序。该程序采用支持向量机方法来实现数据的非线性回归,并通过不同的核函数设置来适应不同类型的数据分布。此外,该程序还提供了数据预处理的方法,使得用户能够更加方便地应用此程序解决实际问题。 #### 二、核心功能与原理 ##### 1. 支持向量机(SVM) 支持向量机是一种监督学习模型,主要用于分类和回归分析。对于非线性回归任务,SVM通过引入核技巧(kernel trick)将原始低维空间中的非线性问题转换为高维空间中的线性问题,从而实现有效的非线性建模。 ##### 2. 核函数 核函数的选择直接影响到模型的性能。本程序内置了三种常用的核函数: - **线性核函数**:`K(x, y) = x'y` - **多项式核函数**:`K(x, y) = (x'y + 1)^d` - **径向基函数(RBF)**:`K(x, y) = exp(-γ|x - y|^2)` 其中RBF核函数被广泛应用于非线性问题中,因为它可以处理非常复杂的非线性关系。本程序默认使用的是RBF核函数,参数`D`用于控制高斯核函数的宽度。 ##### 3. 数据预处理 虽然程序本身没有直接涉及数据预处理的过程,但在实际应用中,对数据进行适当的预处理是非常重要的。常见的预处理步骤包括归一化、缺失值处理等。 ##### 4. 模型参数 - **Epsilon**: ε-insensitive loss function的ε值,控制回归带宽。 - **C**: 松弛变量的惩罚系数,控制模型复杂度与过拟合的风险之间的平衡。 #### 三、程序实现细节 ##### 1. 函数输入与输出 - **输入**: - `X`: 输入特征矩阵,维度为(n, l),其中n是特征数量,l是样本数量。 - `Y`: 目标值向量,长度为l。 - `Epsilon`: 回归带宽。 - `C`: 松弛变量的惩罚系数。 - `D`: RBF核函数的参数。 - **输出**: - `Alpha1`: 正的拉格朗日乘子向量。 - `Alpha2`: 负的拉格朗日乘子向量。 - `Alpha`: 拉格朗日乘子向量。 - `Flag`: 标记向量,表示每个样本的类型。 - `B`: 偏置项。 ##### 2. 核心代码解析 程序首先计算所有样本间的核矩阵`K`,然后构建二次规划问题并求解得到拉格朗日乘子向量。根据拉格朗日乘子的值确定支持向量,并计算偏置项`B`。 - **核矩阵计算**:采用RBF核函数,通过`exp(-(sum((xi-xj).^2)/D))`计算任意两个样本之间的相似度。 - **二次规划**:构建目标函数和约束条件,使用`quadprog`函数求解最小化问题。 - **支持向量识别**:根据拉格朗日乘子的大小判断每个样本是否为支持向量,并据此计算偏置项`B`。 #### 四、程序扩展与优化 - **多核函数支持**:可以通过增加更多的核函数选项,提高程序的灵活性。 - **自动调参**:实现参数自动选择的功能,例如通过交叉验证选择最优的`Epsilon`和`C`值。 - **并行计算**:利用MATLAB的并行计算工具箱加速计算过程,特别是当样本量很大时。 #### 五、应用场景 该程序适用于需要进行非线性回归预测的场景,如经济预测、天气预报等领域。通过调整核函数和参数,可以有效应对各种类型的非线性问题。 ### 总结 本程序提供了一个支持向量机非线性回归的完整实现框架,通过灵活的核函数设置和参数调整,能够有效地处理非线性问题。对于需要进行回归预测的应用场景,这是一个非常实用且强大的工具。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值