PAT甲级1096 Consecutive Factors (20 分)【思维】

7 篇文章 0 订阅

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3×5×6×7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:

Each input file contains one test case, which gives the integer N (1<N<2​31​​).

Output Specification:

For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format factor[1]*factor[2]*...*factor[k], where the factors are listed in increasing order, and 1 is NOT included.

Sample Input:

630

Sample Output:

3
5*6*7

题意:求某一个数的最长最大的连续因子

解题思路:用手机算了,最多不会超过12个连续的因子,如果是质数,则连续因子长度为1,其为它自己,非质数就用2个for循环,每一次连 乘看一下n能不能整除,如果不能就跳出内循环,从外层循环更新,具体的见代码

#include<iostream>
#include<cmath>
using namespace std;
int main(void)
{
	int n;
	scanf("%d",&n);
	int len=0,first=0,temp,maxn=sqrt(n);
	for(int i=2;i<=maxn;i++)
	{
		int j;
		temp=1;
		for(j=i;j<=maxn;j++)
		{
			temp*=j;
			if(n%temp!=0) break;//注意不能整除就退出这个循环,重新找开始的数
		}
		if(j-i>len)
		{
			len=j-i;
			first=i;
		}
	}
	if(first==0) cout<<1<<endl<<n;
    else{
        cout<<len<<endl;
		for(int i=0;i<len;i++)
		{
			cout<<first+i;
			if(i!=len-1) cout<<"*";
		}	
	}	
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值