【PAT甲级 - C++题解】1096 Consecutive Factors

✍个人博客:https://blog.csdn.net/Newin2020?spm=1011.2415.3001.5343
📚专栏地址:PAT题解集合
📝原题地址:题目详情 - 1096 Consecutive Factors (pintia.cn)
🔑中文翻译:连续因子
📣专栏定位:为想考甲级PAT的小伙伴整理常考算法题解,祝大家都能取得满分!
❤️如果有收获的话,欢迎点赞👍收藏📁,您的支持就是我创作的最大动力💪

1096 Consecutive Factors

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3×5×6×7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:

Each input file contains one test case, which gives the integer N (1<N<231).

Output Specification:

For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format factor[1]*factor[2]*...*factor[k], where the factors are listed in increasing order, and 1 is NOT included.

Sample Input:

630

Sample Output:

3
5*6*7
题意

在一个正整数 N 的所有因子中,可能存在几个连续的数字。

例如,630 可以分解为 3 × 5 × 6 × 7 3×5×6×7 3×5×6×7 ,其中 5、6、7 是三个连续的数字。

现在给定任意正整数 N ,请你找到最大连续因子数,并列出连续因子的最小序列。

思路

我们可以枚举每一个起点,然后再去从该起点出发找出连续因子。

注意,题目需要输出最长的连续因子,且最长长度下连续因子的起点需要最小。

代码
#include<bits/stdc++.h>
using namespace std;

int main()
{
    int n;
    cin >> n;

    vector<int> res;
    for (int i = 2; i <= n / i; i++)
        if (n % i == 0)    //判断是否为约数
        {
            vector<int> seq;
            //找出连续因子
            for (int m = n, j = i; m % j == 0; j++)
            {
                seq.push_back(j);
                m /= j;
            }
            //更新最长的连续因子
            if (seq.size() > res.size())   res = seq;
        }

    //如果是质数,则直接输出
    if (res.empty()) res.push_back(n);

    //输出结果
    cout << res.size() << endl;
    cout << res[0];
    for (int i = 1; i < res.size(); i++)   cout << "*" << res[i];
    cout << endl;

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值