PAT甲级1111 Online Map (30 分)【Dijkstra+dfs】

35 篇文章 0 订阅

Input our current position and a destination, an online map can recommend several paths. Now your job is to recommend two paths to your user: one is the shortest, and the other is the fastest. It is guaranteed that a path exists for any request.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (2≤N≤500), and M, being the total number of streets intersections on a map, and the number of streets, respectively. Then M lines follow, each describes a street in the format:

V1 V2 one-way length time

where V1 and V2 are the indices (from 0 to N−1) of the two ends of the street; one-way is 1 if the street is one-way from V1 to V2, or 0 if not; length is the length of the street; and time is the time taken to pass the street.

Finally a pair of source and destination is given.

Output Specification:

For each case, first print the shortest path from the source to the destination with distance D in the format:

Distance = D: source -> v1 -> ... -> destination

Then in the next line print the fastest path with total time T:

Time = T: source -> w1 -> ... -> destination

In case the shortest path is not unique, output the fastest one among the shortest paths, which is guaranteed to be unique. In case the fastest path is not unique, output the one that passes through the fewest intersections, which is guaranteed to be unique.

In case the shortest and the fastest paths are identical, print them in one line in the format:

Distance = D; Time = T: source -> u1 -> ... -> destination

Sample Input 1:

10 15
0 1 0 1 1
8 0 0 1 1
4 8 1 1 1
3 4 0 3 2
3 9 1 4 1
0 6 0 1 1
7 5 1 2 1
8 5 1 2 1
2 3 0 2 2
2 1 1 1 1
1 3 0 3 1
1 4 0 1 1
9 7 1 3 1
5 1 0 5 2
6 5 1 1 2
3 5

Sample Output 1:

Distance = 6: 3 -> 4 -> 8 -> 5
Time = 3: 3 -> 1 -> 5

Sample Input 2:

7 9
0 4 1 1 1
1 6 1 1 3
2 6 1 1 1
2 5 1 2 2
3 0 0 1 1
3 1 1 1 3
3 2 1 1 2
4 5 0 2 2
6 5 1 1 2
3 5

Sample Output 2:

Distance = 3; Time = 4: 3 -> 2 -> 5

题意:给出n和m2个数,n表示街2头,m表示街的数量,然后给出m行的街2头和flag(单行道还是双向的)以及这条街的长度和所花费的时间,要求的是最短路径和最快的路径。

解题思路:Dijkstra,用2次,一次求最短的,一次求最快的,然后dfs打印最短的路径和最快的路径,有点懒,我懒得说了

#include<iostream>
#include<cstdio>
#include<vector>
using namespace std;
const int inf=0x3f3f3f3f;
bool vis[520];
int dispre[520],timepre[520],e[520][520],t[520][520],dis[520],tim[520],distim[520],nodenum[520];
int st,en;
vector<int>dispath,timepath;
void dfsdispath(int v)
{
	if(v==st)
	{
		dispath.push_back(v);
		return ;
	}
	dfsdispath(dispre[v]);
	dispath.push_back(v);
}
void dfstimepath(int v)
{
	if(v==st)
	{
		timepath.push_back(v);
		return ;
	}
	dfstimepath(timepre[v]);
	timepath.push_back(v);
}
int main(void)
{
	fill(dis,dis+520,inf);
	fill(tim,tim+520,inf);
	fill(t[0],t[0]+520*520,inf);
	fill(e[0],e[0]+520*520,inf);
	fill(distim,distim+520,inf);
	int n,m;
	scanf("%d %d",&n,&m);
	int a,b,flag,len,ti;
	for(int i=0;i<m;i++)
	{
		scanf("%d %d %d %d %d",&a,&b,&flag,&len,&ti);
		e[a][b]=len;
		t[a][b]=ti;
		if(flag!=1)
		{
			e[b][a]=len;
			t[b][a]=ti;
		}
	}
	scanf("%d %d",&st,&en);
	dis[st]=0;
	for(int i=0;i<n;i++) dispre[i]=i;
	for(int i=0;i<n;i++)
	{
		int u=-1,minn=inf;
		for(int j=0;j<n;j++)
		{
			if(vis[j]==false&&dis[j]<minn)
			{
				u=j;
				minn=dis[j];
			}
		}
		if(u==-1) break;
	    vis[u]=true;
		for(int v=0;v<n;v++)
		{
			if(vis[v]==false&&e[u][v]!=inf)
			{
				if(dis[u]+e[u][v]<dis[v])
				{
					dis[v]=dis[u]+e[u][v];
					dispre[v]=u;
					distim[v]=distim[u]+t[u][v];
				}else if(dis[u]+e[u][v]==dis[v]&&distim[u]+t[u][v]<distim[v])
				{
					distim[v]=distim[u]+t[u][v];
					dispre[v]=u;
				 } 
			}
		}
	}
//	printf("%d",dis[en]); 
	dfsdispath(en);
	tim[st]=0;
	fill(vis,vis+520,false);
	for(int i=0;i<n;i++)
	{
		int u=-1,minn=inf;
		for(int j=0;j<n;j++)
		{
			if(vis[j]==false&&tim[j]<minn)
			{
				u=j;
				minn=tim[j];
			}
		}
		if(u==-1) break;
		vis[u]=true;
		for(int v=0;v<n;v++)
		{
			if(vis[v]==false&&e[u][v]!=inf)
			{
				if(tim[u]+t[u][v]<tim[v])
				{
					tim[v]=tim[u]+t[u][v];
					timepre[v]=u;
					nodenum[v]=nodenum[u]+1;
				}else if(tim[u]+t[u][v]==tim[v]&&nodenum[u]+1<nodenum[v])
				{
					nodenum[v]=nodenum[u]+1;
					timepre[v]=u;
				 } 
			}
		}
	}
	dfstimepath(en);
	//printf("%d",dis[en]);
	if(timepath==dispath)
	{
		printf("Distance = %d; Time = %d: ",dis[en],tim[en]);
		for(int i=0;i<dispath.size();i++)
		{
			printf("%d",dispath[i]);
			if(i!=dispath.size()-1) printf(" -> ");
		}
	}else
	{
		printf("Distance = %d: ",dis[en]);
		for(int i=0;i<dispath.size();i++)
		{
			printf("%d",dispath[i]);
			if(i!=dispath.size()-1) printf(" -> ");
		}
		printf("\nTime = %d: ",tim[en]);
		for(int i=0;i<timepath.size();i++)
		{
			printf("%d",timepath[i]);
			if(i!=timepath.size()-1) printf(" -> ");
		}
	}
	
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值