HDU 1087 Super Jumping! Jumping! Jumping!


B - Super Jumping! Jumping! Jumping!
Crawling in process... Crawling failed Time Limit:1000MS    Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Appoint description:

Description

Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.



The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.
 

Input

Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.
 

Output

For each case, print the maximum according to rules, and one line one case.
 

Sample Input

     
     
3 1 3 2 4 1 2 3 4 4 3 3 2 1 0
 

Sample Output

     
     
4 10 3
题意:你需要从棋盘上的起点跳到终点,给出中间点的数值,你只能从小的跳到大的数来获得该点分数,且不能回头,
目标是取得最大分数,求该最大分数。可以从起点直接跳到终点,分数为0。
(数据都是非负的,不需要特判,已尝试。)
思路:开始思路有点乱,WA了5次,冷静想想,理清思路后其实并不是很难!
flag[]数组含义:flag[i]表示从起点跳到以chess[i]为终点可以获得的最大分数。(最大上升子序列和)
用个标记数组flag[],初始化时存储各个原始数据chess[],然后从前往后求每个chess[]数值前比其小且
flag[]值要是最大的才加到chess[]中,最后取flag[]数组最大值即为答案ans.
代码如下:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
#ifdef OFFLINE
	freopen("t.txt","r", stdin);
#endif
	int flag[1002], chess[1002], i, j, n, maxn;
	while(scanf("%d", &n)&&n != 0){
		for(i=1;i<=n;i++){
		     scanf("%d", &chess[i]);//flag[i]表示以c[i]为终点的上升子序列和
		     flag[i]=chess[i];//初始化为其自身值
		}
		int ans=0;
		for(i=1;i<=n;i++){//前往后求
			maxn=0;
			for(j=1;j<i;j++){
				if(chess[i]>chess[j])//比其大且要flag[]最大
					maxn=max(maxn, flag[j]);
			}
			flag[i]+=maxn;
		}
		for(i=1;i<=n;i++)
			ans=max(ans, flag[i]);
		printf("%d\n", ans);
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值