POJ 3020 Antenna Placement(二分图匹配)


Antenna Placement
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

The Global Aerial Research Centre has been allotted the task of building the fifth generation of mobile phone nets in Sweden. The most striking reason why they got the job, is their discovery of a new, highly noise resistant, antenna. It is called 4DAir, and comes in four types. Each type can only transmit and receive signals in a direction aligned with a (slightly skewed) latitudinal and longitudinal grid, because of the interacting electromagnetic field of the earth. The four types correspond to antennas operating in the directions north, west, south, and east, respectively. Below is an example picture of places of interest, depicted by twelve small rings, and nine 4DAir antennas depicted by ellipses covering them. 

Obviously, it is desirable to use as few antennas as possible, but still provide coverage for each place of interest. We model the problem as follows: Let A be a rectangular matrix describing the surface of Sweden, where an entry of A either is a point of interest, which must be covered by at least one antenna, or empty space. Antennas can only be positioned at an entry in A. When an antenna is placed at row r and column c, this entry is considered covered, but also one of the neighbouring entries (c+1,r),(c,r+1),(c-1,r), or (c,r-1), is covered depending on the type chosen for this particular antenna. What is the least number of antennas for which there exists a placement in A such that all points of interest are covered? 

Input

On the first row of input is a single positive integer n, specifying the number of scenarios that follow. Each scenario begins with a row containing two positive integers h and w, with 1 <= h <= 40 and 0 < w <= 10. Thereafter is a matrix presented, describing the points of interest in Sweden in the form of h lines, each containing w characters from the set ['*','o']. A '*'-character symbolises a point of interest, whereas a 'o'-character represents open space. 

Output

For each scenario, output the minimum number of antennas necessary to cover all '*'-entries in the scenario's matrix, on a row of its own.

Sample Input

2
7 9
ooo**oooo
**oo*ooo*
o*oo**o**
ooooooooo
*******oo
o*o*oo*oo
*******oo
10 1
*
*
*
o
*
*
*
*
*
*

Sample Output

17
5


题意:如图所示,有 x 个星星,你需要用最少的圈圈将所有星星包围(覆盖),

            一个圈圈最多覆盖 2 个星星,可以向上下左右 4 个方向延伸。

思路:查了题解,不是很懂,贴下代码吧。

           建无向边,求出最大匹配后    最少圈数= (星星个数-最大匹配/2)。

代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define N 500
char map[N][N];
int g[N][N], vis[N], flag[N][N], link[N], nx, ny, total;
int path(int u)
{
	for(int i=0;i<ny;i++)
	{
		if(!vis[i] && g[u][i])
		{
			vis[i]=1;
			if(link[i]==-1 || path(link[i]))
			{
				link[i]=u;//反向指向
				return 1;
			}
		}
	}
	return 0;
}
void maxMatch()
{
	int ans=0;
	memset(link,-1,sizeof(link));
	for(int i=0;i<nx;i++){
	   memset(vis, 0, sizeof(vis));
	   ans+=path(i);
	}
	printf("%d\n", total-ans/2);//无向边所以除以2
}
int main()
{
#ifdef OFFLINE
	freopen("t.txt","r",stdin);
#endif
	int i, j, n , h, w;
	scanf("%d",&n);
	while(n--)
	{
		scanf("%d%d",&h,&w);
		total=0;
		for(i=0;i<h;i++)//注意字符串是从下标0开始!
		{
			scanf("%s",map[i]);
			for(j=0;j<w;j++)
			{
				if(map[i][j]=='*') 
					flag[i][j]=total++;//存储星星标号(必须0开始)
			}
		}
		memset(g,0,sizeof(g));
		for(i=0;i<h;i++)
		{
			for(j=0;j<w;j++){
				if(map[i][j]=='*')
				{
					if(i>0 && map[i-1][j]=='*') //上下连线(双向)
						g[flag[i][j]][flag[i-1][j]]=g[flag[i-1][j]][flag[i][j]]=1;
					if(j>0 && map[i][j-1]=='*') //左右连线
						g[flag[i][j]][flag[i][j-1]]=g[flag[i][j-1]][flag[i][j]]=1;
				}
			}
		}
		nx=ny=total;//星星个数作为行列数
		maxMatch();
	}
	return 0;
}



















评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值