poj 1789--Truck History 最小生成树(prim)


Truck History
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on. 

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as 
1/Σ(to,td)d(to,td)

where the sum goes over all pairs of types in the derivation plan such that t  o is the original type and t  d the type derived from it and d(t  o,t  d) is the distance of the types. 
Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan. 

Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

Output

For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.

Sample Input

4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0

Sample Output

The highest possible quality is 1/3.


题意:边之间的权值是由 2 个字符窜之间字符差异个数决定的,除了第一个字符窜,

           其它的字符窜都可是由其它字符窜派生演变而来(只由一个演变而来),请决

           定一种演变方式,使得 1 / Q 值最大即所有的权值之和分母 Q 最小。

思路:直接用 prim 算法求最小生成树。

代码如下:


#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
#define s 2100
#define inf 0x3f3f3f3f
int vis[s], minq[s], derive[s][s], n;
char type[s][10];
void prim()
{
	int i, j, mindis = 0;
	memset(vis, 0, sizeof(vis));
	memset(minq, inf, sizeof(minq));
	minq[1]=0;
	while(1)
	{
		int min=inf, k=-1;
		for(i=1;i<=n;i++){
			if(!vis[i]&&(k==-1 || minq[i]<min))
			{
				k=i; 
				min=minq[i];
			}
		}
		if(k==-1)  break;
		vis[k]=1;
		mindis+=minq[k];
		for(i=1;i<=n;i++){
			if(!vis[i]&&derive[k][i]<minq[i])
				minq[i]=derive[k][i];
		}
	}
	printf("The highest possible quality is 1/%d.\n",mindis);
}
int main()
{
#ifdef OFFLINE
	freopen("t.txt","r",stdin);
#endif
	int i, j, k;
	while(~scanf("%d",&n)&&n)
	{
		for(i=1;i<=n;i++)
			scanf("%s", type[i]);
		memset(derive,0,sizeof(derive));
		for(i=1;i<n;i++){
			for(j=i+1;j<=n;j++){
				for(k=0;k<7;k++){
					if(type[i][k]!=type[j][k])
						derive[i][j]++;//权值
				}
				derive[j][i]=derive[i][j];//双向
			}
		}
		prim();//最小生成树
	}
	return 0;
}















评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值