Minimal Ratio Tree

Minimal Ratio Tree

Time Limit : 2000/1000ms (Java/Other) Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 28 Accepted Submission(s) : 15
Font: Times New Roman | Verdana | Georgia
Font Size: ← →
Problem Description
For a tree, which nodes and edges are all weighted, the ratio of it is calculated according to the following equation.

Given a complete graph of n nodes with all nodes and edges weighted, your task is to find a tree, which is a sub-graph of the original graph, with m nodes and whose ratio is the smallest among all the trees of m nodes in the graph.
Input
Input contains multiple test cases. The first line of each test case contains two integers n (2<=n<=15) and m (2<=m<=n), which stands for the number of nodes in the graph and the number of nodes in the minimal ratio tree. Two zeros end the input. The next line contains n numbers which stand for the weight of each node. The following n lines contain a diagonally symmetrical n×n connectivity matrix with each element shows the weight of the edge connecting one node with another. Of course, the diagonal will be all 0, since there is no edge connecting a node with itself.

All the weights of both nodes and edges (except for the ones on the diagonal of the matrix) are integers and in the range of [1, 100].

The figure below illustrates the first test case in sample input. Node 1 and Node 3 form the minimal ratio tree.

Output
For each test case output one line contains a sequence of the m nodes which constructs the minimal ratio tree. Nodes should be arranged in ascending order. If there are several such sequences, pick the one which has the smallest node number; if there’s a tie, look at the second smallest node number, etc. Please note that the nodes are numbered from 1 .
Sample Input
3 2
30 20 10
0 6 2
6 0 3
2 3 0
2 2
1 1
0 2
2 0
0 0
Sample Output
1 3
1 2
Source
2008 Asia Regional Beijing

#include<iostream>
#include<cstdio>
#include<iomanip>
#include<algorithm>
#include<cstring>
#include<cmath>
using namespace std;
#define INF 999999
#define maxsize 110
int n, m;bool vist[maxsize];
int map[maxsize][maxsize];
int Nodep[maxsize];
int dis[maxsize];
int ans[maxsize];
bool chose[maxsize];
double minn;
double Prim(int f) {
    int i, j, x;
    memset(vist, 0, sizeof(vist));
    for (i = 0;i < 20;i++)
        dis[i] = 10000000;
    dis[f] = 0;
    int minx, min, ansx = 0;;
    for (i = 1;i <= m;i++) {
        min = 100000000;
        for (j = 1;j <= n;j++)
            if (chose[j] && !vist[j] && dis[j] < min) {
                min = dis[j];
                minx = j;
            }
        vist[minx] = 1;
        ansx += dis[minx];
        dis[minx] = 0;
        for (j = 1;j <= n;j++)
            if (chose[j] && !vist[j] && map[minx][j] < dis[j])
                dis[j] = map[minx][j];
    }
    return ansx * 1.0;
}

void Dfs(int p, int c) {
    if (c == m) {
        int first = 0;;
        int countn = 0;
        double tem, tem1, tem2 = 0;

        for (int i = 1;i <= n;i++)
            if (chose[i]) {
                if (!first) {
                    first = i;
                    tem1 = Prim(first);
                }
                tem2 += Nodep[i] * 1.0;
            }

        tem = tem1 / tem2;
        if (tem <  minn) {
            minn = tem;
            for (int i = 1;i <= n;i++)
                if (chose[i]) {
                    ans[countn] = i;
                    countn++;
                }
        }
        return;
    }
    chose[p] = 1;
    Dfs(p + 1, c + 1);
    chose[p] = 0;
    if (n - p + c >= m)
        Dfs(p + 1, c);
}

int main()
{
    while (cin >> n >> m&&n&&m)
    {
        int t;
        //memset(Nodep, 0, sizeof(dis));
        memset(chose, 0, sizeof(chose));
        minn = INF;
        for (int i = 1;i <= n;i++)
        {
            cin >> Nodep[i];
        }
        //memset(map, 0, sizeof(map));
        for (int i = 1;i <= n;i++)
        {
            for (int j = 1;j <= n;j++)
            {
                cin >> t;
                map[i][j]  = t;
            }
        }
        Dfs(1, 0);
        for (int i = 0;i < m - 1;i++)
        {
            cout << ans[i] << " ";
        }
        cout << ans[m-1] << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值