String painter

String painter

Time Limit : 5000/2000ms (Java/Other) Memory Limit : 32768/32768K (Java/Other)

Total Submission(s) : 22 Accepted Submission(s) : 14

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

There are two strings A and B with equal length. Both strings are made up of lower case letters. Now you have a powerful string painter. With the help of the painter, you can change a segment of characters of a string to any other character you want. That is, after using the painter, the segment is made up of only one kind of character. Now your task is to change A to B using string painter. What’s the minimum number of operations?

Input

Input contains multiple cases. Each case consists of two lines:
The first line contains string A.
The second line contains string B.
The length of both strings will not be greater than 100.

Output

A single line contains one integer representing the answer.

Sample Input

zzzzzfzzzzz
abcdefedcba
abababababab
cdcdcdcdcdcd

Sample Output

6
7

Source

2008 Asia Regional Chengdu

Statistic | Submit | Back

比较复杂的区间DP

#include<iostream>
#include<string>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
#define maxsize 105
char s1[maxsize];
char s2[maxsize];
int dp[maxsize][maxsize];
int ans[maxsize];

int main()
{
    while (scanf("%s%s", s1, s2) != EOF)
    {
        int len = strlen(s1);

        memset(dp, 0, sizeof(dp));
        for (int j = 0; j < len; j++)
        {
            for (int i = j; i >= 0; i--)
            {
                dp[i][j] = dp[i + 1][j] + 1;
                for (int k = i + 1; k <= j; k++)
                {
                    if (s2[i] == s2[k])
                        dp[i][j] = min(dp[i][j], dp[i + 1][k] + dp[k + 1][j]);
                }
            }
        }
        for (int i = 0; i < len; i++)
        {
            ans[i] = dp[0][i];
        }
        for (int i = 0; i < len; i++)
        {
            if (s1[i] == s2[i])
            {
                ans[i] = ans[i - 1];
            }
            else
            {
                for (int j = 0; j < i; j++)
                {
                    ans[i] = min(ans[i], ans[j] + dp[j + 1][i]);
                }
            }
        }
        printf("%d\n", ans[len - 1]);
    }
    system("pause");
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值